# CVE-2022-41905: wsgidav is vulnerable to Cross-Site Scripting (XSS) when directory browsing is enabled

> Attackers can execute arbitrary scripts in user browsers via XSS in WsgiDAV when directory browsing is enabled.

- **Severity:** High 8.2 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 11 Nov 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-xx6g-jj35-pxjv, PYSEC-2022-43018

## What is CVE-2022-41905?

CVE-2022-41905 is a high-severity cross-site scripting vulnerability in mar10 wsgidav, published on 11 Nov 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

WsgiDAV is a generic and extendable WebDAV server based on WSGI. Implementations using this library with directory browsing enabled may be susceptible to Cross Site Scripting (XSS) attacks. This issue has been patched, users can upgrade to version 4.1.0. As a workaround, set `dir_browser.enable = False` in the configuration.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-41905?

3 open source packages ship an affected version, including wsgidav. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wsgidav` | PyPI | From 3.0.0 | 4.1.0 |
| `wsgidav` | PyPI | From 3.0.0a1 | 4.1.0 |
| `wsgidav` | PyPI | From 3.0.0a1 | 4.1.0 |

Products: Wsgidav Project Wsgidav.

## How do I fix CVE-2022-41905?

Upgrade wsgidav to 4.1.0 or later.

## Is CVE-2022-41905 being exploited?

There is no known exploitation of CVE-2022-41905 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-41905 and fix it if it is affected.

What it is: CVE-2022-41905 is a high-severity cross-site scripting vulnerability in mar10 wsgidav, published on 11 Nov 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-41905 in the wild and no public exploit code.

Affected packages and fixed versions:
- wsgidav (PyPI): affected from 3.0.0; fixed in 4.1.0
- wsgidav (PyPI): affected from 3.0.0a1; fixed in 4.1.0
- wsgidav (PyPI): affected from 3.0.0a1; fixed in 4.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-41905/ (Markdown: https://insights.sbomify.com/CVE-2022-41905/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-41905
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-41905
- OSV: https://osv.dev/vulnerability/CVE-2022-41905

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-41905/
Summaries are generated and may contain mistakes; the official description above is the record.
