{"answers":{"affected":"2 open source packages ship an affected version, including io.netty:netty-codec-http. It affects 2 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-41915 exists.","fix":"Upgrade io.netty:netty-codec-http to 4.1.86.Final or later.","what":"CVE-2022-41915 is a medium-severity vulnerability in Debian Debian Linux, published on 13 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-41915 and fix it if it is affected.\n\nWhat it is: CVE-2022-41915 is a medium-severity vulnerability in Debian Debian Linux, published on 13 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-41915 exists.\n\nAffected packages and fixed versions:\n- io.netty:netty-codec-http (Maven): affected from 4.1.83.Final; fixed in 4.1.86.Final\n- io.netty:netty-codec-http (Maven): affected from 4.1.83.Final; fixed in 4.1.86.Final\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-41915/ (Markdown: https://insights.sbomify.com/CVE-2022-41915/index.md)","id":"CVE-2022-41915","markdown":"https://insights.sbomify.com/CVE-2022-41915/index.md","name":"CVE-2022-41915","record":{"aliases":["CLSA-2026-1792580190","DEBIAN-CVE-2022-41915","GHSA-hh82-3pmq-7frp","UBUNTU-CVE-2022-41915"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Netty network framework","requires_auth":"none","summary":"Attackers can perform HTTP Response Splitting by injecting malicious header values via the DefaultHttpHeaders.set iterator method in Netty.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"netty","vendor":"netty"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-436","name":"Interpretation Conflict"},{"id":"CWE-113","name":"Improper Neutralization of CRLF Sequences in HTTP Headers"}],"description":"Netty project is an event-driven asynchronous network application framework. Starting in version 4.1.83.Final and prior to 4.1.86.Final, when calling `DefaultHttpHeadesr.set` with an _iterator_ of values, header value validation was not performed, allowing malicious header values in the iterator to perform HTTP Response Splitting. This issue has been patched in version 4.1.86.Final. Integrators can work around the issue by changing the `DefaultHttpHeaders.set(CharSequence, Iterator\u003c?\u003e)` call, into a `remove()` call, and call `add()` in a loop over the iterator of values.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Netty vulnerable to HTTP Response splitting from assigning header value iterator","id":"CVE-2022-41915","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"debian:debian_linux","products":["debian:debian_linux","netty:netty"],"type":"other","year":"2022"},"n_packages":2,"n_references":7,"next":{"headline":"Read one byte past a buffer when normalizing Unicode","id":"CVE-2022-41916"},"packages":[{"ecosystem":"Maven","fixed":["4.1.86.Final"],"introduced":["4.1.83.Final"],"last_affected":[],"package":"io.netty:netty-codec-http","purl":null,"source":"GHSA-hh82-3pmq-7frp"},{"ecosystem":"Maven","fixed":["4.1.86.Final"],"introduced":["4.1.83.Final"],"last_affected":[],"package":"io.netty:netty-codec-http","purl":"pkg:maven/io.netty/netty-codec-http","source":"GHSA-hh82-3pmq-7frp"}],"prev":{"headline":"Non-constant-time SCIM token comparison in Zulip Server","id":"CVE-2022-41914"},"products":["netty"],"published":"2022-12-13","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-22","vendors":["netty"]},"summary":"Attackers can perform HTTP Response Splitting by injecting malicious header values via the DefaultHttpHeaders.set iterator method in Netty.","url":"https://insights.sbomify.com/CVE-2022-41915/"}