# CVE-2022-41915: Netty vulnerable to HTTP Response splitting from assigning header value iterator

> Attackers can perform HTTP Response Splitting by injecting malicious header values via the DefaultHttpHeaders.set iterator method in Netty.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Dec 2022
- **Updated:** 22 Apr 2025
- **Also known as:** CLSA-2026-1792580190, DEBIAN-CVE-2022-41915, GHSA-hh82-3pmq-7frp, UBUNTU-CVE-2022-41915

## What is CVE-2022-41915?

CVE-2022-41915 is a medium-severity vulnerability in Debian Debian Linux, published on 13 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Netty project is an event-driven asynchronous network application framework. Starting in version 4.1.83.Final and prior to 4.1.86.Final, when calling `DefaultHttpHeadesr.set` with an _iterator_ of values, header value validation was not performed, allowing malicious header values in the iterator to perform HTTP Response Splitting. This issue has been patched in version 4.1.86.Final. Integrators can work around the issue by changing the `DefaultHttpHeaders.set(CharSequence, Iterator<?>)` call, into a `remove()` call, and call `add()` in a loop over the iterator of values.

Weakness: CWE-436 (Interpretation Conflict), CWE-113 (Improper Neutralization of CRLF Sequences in HTTP Headers)

## Which versions are affected by CVE-2022-41915?

2 open source packages ship an affected version, including io.netty:netty-codec-http. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.netty:netty-codec-http` | Maven | From 4.1.83.Final | 4.1.86.Final |
| `io.netty:netty-codec-http` | Maven | From 4.1.83.Final | 4.1.86.Final |

Products: Debian Debian Linux, Netty Netty.

## How do I fix CVE-2022-41915?

Upgrade io.netty:netty-codec-http to 4.1.86.Final or later.

## Is CVE-2022-41915 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-41915 exists.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-41915 and fix it if it is affected.

What it is: CVE-2022-41915 is a medium-severity vulnerability in Debian Debian Linux, published on 13 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-41915 exists.

Affected packages and fixed versions:
- io.netty:netty-codec-http (Maven): affected from 4.1.83.Final; fixed in 4.1.86.Final
- io.netty:netty-codec-http (Maven): affected from 4.1.83.Final; fixed in 4.1.86.Final

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-41915/ (Markdown: https://insights.sbomify.com/CVE-2022-41915/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-41915
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-41915
- OSV: https://osv.dev/vulnerability/CVE-2022-41915

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-41915/
Summaries are generated and may contain mistakes; the official description above is the record.
