CVE-2022-41916 Read one byte past a buffer when normalizing Unicode

Medium 5.9 Published Updated

An attacker can cause a denial of service by triggering a buffer over-read during Unicode normalization in the Heimdal PKI certificate validation library.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-41916?

CVE-2022-41916 is a medium-severity denial of service vulnerability in Debian Debian Linux, published on 15 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Heimdal is an implementation of ASN.1/DER, PKIX, and Kerberos. Versions prior to 7.7.1 are vulnerable to a denial of service vulnerability in Heimdal's PKI certificate validation library, affecting the KDC (via PKINIT) and kinit (via PKINIT), as well as any third-party applications using Heimdal's libhx509. Users should upgrade to Heimdal 7.7.1 or 7.8. There are no known workarounds for this issue.

Weakness: CWE-193

Which versions are affected by CVE-2022-41916?

It affects 2 products.

Products include Debian Debian Linux, Heimdal Project Heimdal.

How do I fix CVE-2022-41916?

Upgrade to a fixed version.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2022-41916 being exploited?

There is no known exploitation of CVE-2022-41916 in the wild and no public exploit code.

All Debian Debian Linux vulnerabilities

Sources

Also known as ALPINE-CVE-2022-41916, AZL-11457, AZL-44835, CLEANSTART-2024-TH83400, DEBIAN-CVE-2022-41916, GHSA-mgqr-gvh6-23cx and 2 more.

Is CVE-2022-41916 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free