# CVE-2022-41916: Read one byte past a buffer when normalizing Unicode

> An attacker can cause a denial of service by triggering a buffer over-read during Unicode normalization in the Heimdal PKI certificate validation library.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Nov 2022
- **Updated:** 23 Apr 2025
- **Also known as:** ALPINE-CVE-2022-41916, AZL-11457, AZL-44835, CLEANSTART-2024-TH83400, DEBIAN-CVE-2022-41916, GHSA-mgqr-gvh6-23cx, UBUNTU-CVE-2022-41916, USN-5766-1

## What is CVE-2022-41916?

CVE-2022-41916 is a medium-severity denial of service vulnerability in Debian Debian Linux, published on 15 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Heimdal is an implementation of ASN.1/DER, PKIX, and Kerberos. Versions prior to 7.7.1 are vulnerable to a denial of service vulnerability in Heimdal's PKI certificate validation library, affecting the KDC (via PKINIT) and kinit (via PKINIT), as well as any third-party applications using Heimdal's libhx509. Users should upgrade to Heimdal 7.7.1 or 7.8. There are no known workarounds for this issue.

Weakness: CWE-193 (Off-by-one Error)

## Which versions are affected by CVE-2022-41916?

It affects 2 products.


Products: Debian Debian Linux, Heimdal Project Heimdal.

## How do I fix CVE-2022-41916?

Upgrade to a fixed version.

## Is CVE-2022-41916 being exploited?

There is no known exploitation of CVE-2022-41916 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-41916 and fix it if it is affected.

What it is: CVE-2022-41916 is a medium-severity denial of service vulnerability in Debian Debian Linux, published on 15 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-41916 in the wild and no public exploit code.

Affected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-41916/ (Markdown: https://insights.sbomify.com/CVE-2022-41916/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-41916
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-41916
- OSV: https://osv.dev/vulnerability/CVE-2022-41916

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-41916/
Summaries are generated and may contain mistakes; the official description above is the record.
