# CVE-2022-41920: Zip slip in Lancet

> Attackers can exploit a Zip Slip vulnerability in the Lancet Go library to write files outside the intended directory, potentially leading to code execution or data modification.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Nov 2022
- **Updated:** 22 Apr 2025
- **Also known as:** GHSA-pp3f-xrw5-q5j4, GO-2022-1114

## What is CVE-2022-41920?

CVE-2022-41920 is a medium-severity path traversal vulnerability in duke-git lancet, published on 17 Nov 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Lancet is a general utility library for the go programming language. Affected versions are subject to a ZipSlip issue when using the fileutil package to unzip files. This issue has been addressed and a fix will be included in versions 2.1.10 and 1.3.4. Users are advised to upgrade. There are no known workarounds for this issue.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2022-41920?

6 open source packages ship an affected version, including github.com/duke-git/lancet and github.com/duke-git/lancet/v2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/duke-git/lancet` | Go | All versions | 1.3.4 |
| `github.com/duke-git/lancet` | Go | All versions | 1.3.4 |
| `github.com/duke-git/lancet` | Go | All versions | 1.3.4 |
| `github.com/duke-git/lancet/v2` | Go | From 2.0.0 | 2.1.10 |
| `github.com/duke-git/lancet/v2` | Go | From 2.0.0 | 2.1.10 |
| `github.com/duke-git/lancet/v2` | Go | From 2.0.0 | 2.1.10 |

Products: Lancet Project Lancet.

## How do I fix CVE-2022-41920?

Upgrade github.com/duke-git/lancet to 1.3.4 or later.

## Is CVE-2022-41920 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-41920 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-41920 and fix it if it is affected.

What it is: CVE-2022-41920 is a medium-severity path traversal vulnerability in duke-git lancet, published on 17 Nov 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-41920 exists.

Affected packages and fixed versions:
- github.com/duke-git/lancet (Go): affected all versions; fixed in 1.3.4
- github.com/duke-git/lancet (Go): affected all versions; fixed in 1.3.4
- github.com/duke-git/lancet (Go): affected all versions; fixed in 1.3.4
- github.com/duke-git/lancet/v2 (Go): affected from 2.0.0; fixed in 2.1.10
- github.com/duke-git/lancet/v2 (Go): affected from 2.0.0; fixed in 2.1.10
- github.com/duke-git/lancet/v2 (Go): affected from 2.0.0; fixed in 2.1.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-41920/ (Markdown: https://insights.sbomify.com/CVE-2022-41920/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-41920
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-41920
- OSV: https://osv.dev/vulnerability/CVE-2022-41920

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-41920/
Summaries are generated and may contain mistakes; the official description above is the record.
