# CVE-2022-41921: Discourse chat messages should have a maximum character limit

> Attackers can cause denial of service by posting unlimited length chat messages, requiring users to upgrade Discourse.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 Nov 2022
- **Updated:** 23 Apr 2025
- **Also known as:** BIT-discourse-2022-41921, GHSA-mfh7-6cv6-qccc

## What is CVE-2022-41921?

CVE-2022-41921 is a low-severity denial of service vulnerability in Discourse Discourse, published on 28 Nov 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Discourse is an open-source discussion platform. Prior to version 2.9.0.beta13, users can post chat messages of an unlimited length, which can cause a denial of service for other users when posting huge amounts of text. Users should upgrade to version 2.9.0.beta13, where a limit has been introduced. No known workarounds are available.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2022-41921?

1 open source package ship an affected version, including discourse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | All versions | 2.9.0 |

Products: Discourse Discourse.

## How do I fix CVE-2022-41921?

Upgrade discourse to 2.9.0 or later.

## Is CVE-2022-41921 being exploited?

There is no known exploitation of CVE-2022-41921 in the wild and no public exploit code.

## Other vulnerabilities in Discourse Discourse

- [CVE-2021-41163](https://insights.sbomify.com/CVE-2021-41163/): RCE via malicious SNS subscription payload (critical 10.0)
- [CVE-2022-36066](https://insights.sbomify.com/CVE-2022-36066/): Discourse vulnerable to RCE via admins uploading maliciously zipped file (critical 9.1)
- [CVE-2022-39356](https://insights.sbomify.com/CVE-2022-39356/): Discourse user account takeover via email and invite link (high 8.9)
- [CVE-2023-22468](https://insights.sbomify.com/CVE-2023-22468/): Discourse vulnerable to Cross-site Scripting in local oneboxes (high 8.8)
- [CVE-2026-27934](https://insights.sbomify.com/CVE-2026-27934/): Discourse leaks private topic title and post excerpt via user action API endpoint (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-41921 and fix it if it is affected.

What it is: CVE-2022-41921 is a low-severity denial of service vulnerability in Discourse Discourse, published on 28 Nov 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-41921 in the wild and no public exploit code.

Affected packages and fixed versions:
- discourse (Bitnami): affected all versions; fixed in 2.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-41921/ (Markdown: https://insights.sbomify.com/CVE-2022-41921/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-41921
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-41921
- OSV: https://osv.dev/vulnerability/CVE-2022-41921

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-41921/
Summaries are generated and may contain mistakes; the official description above is the record.
