{"answers":{"affected":"2 open source packages ship an affected version, including yiisoft/yii. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-41922 in the wild and no public exploit code.","fix":"Upgrade yiisoft/yii to 1.1.27 or later.","what":"CVE-2022-41922 is a high-severity unsafe deserialization vulnerability in yiisoft yii, published on 23 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-41922 and fix it if it is affected.\n\nWhat it is: CVE-2022-41922 is a high-severity unsafe deserialization vulnerability in yiisoft yii, published on 23 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-41922 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- yiisoft/yii (Packagist): affected all versions; fixed in 1.1.27\n- yiisoft/yii (Packagist): affected all versions; fixed in 1.1.27\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-41922/ (Markdown: https://insights.sbomify.com/CVE-2022-41922/index.md)","id":"CVE-2022-41922","markdown":"https://insights.sbomify.com/CVE-2022-41922/index.md","name":"CVE-2022-41922","record":{"aliases":["GHSA-442f-wcwq-fpcf"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Yii PHP framework","requires_auth":"none","summary":"Attackers can achieve remote code execution if the application unsafely deserializes user input using the Yii framework.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"yii","vendor":"yiiframework"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"`yiisoft/yii` before version 1.1.27 are vulnerable to Remote Code Execution (RCE) if the application calls `unserialize()` on arbitrary user input. This has been patched in 1.1.27.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Prevent RCE when deserializing untrusted user input","id":"CVE-2022-41922","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"deserialization","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"Grails Spring Security Core plugin vulnerable to privilege escalation","id":"CVE-2022-41923"},"packages":[{"ecosystem":"Packagist","fixed":["1.1.27"],"introduced":["0"],"last_affected":[],"package":"yiisoft/yii","purl":null,"source":"GHSA-442f-wcwq-fpcf"},{"ecosystem":"Packagist","fixed":["1.1.27"],"introduced":["0"],"last_affected":[],"package":"yiisoft/yii","purl":"pkg:composer/yiisoft/yii","source":"GHSA-442f-wcwq-fpcf"}],"prev":{"headline":"Discourse chat messages should have a maximum character limit","id":"CVE-2022-41921"},"products":["yii"],"published":"2022-11-23","related":[{"cvss_score":9,"headline":"Yiiframework Yii Improper Protection of Alternate Path","id":"CVE-2024-58136","kev_date_added":"2025-05-02","published":"2025-04-10"},{"cvss_score":9.8,"headline":"Yii2 allows attackers to execute any local .php file via a relative path in the view parameter","id":"CVE-2015-5467","kev_date_added":null,"published":"2023-09-21"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2023-26750","kev_date_added":null,"published":"2023-04-04"},{"cvss_score":9.8,"headline":"Yii SQL injection vulnerability","id":"CVE-2018-7269","kev_date_added":null,"published":"2018-03-21"},{"cvss_score":9.8,"headline":"yii2-redis Potential Remote code execution","id":"CVE-2018-8073","kev_date_added":null,"published":"2018-03-21"},{"cvss_score":8.9,"headline":"Unsafe deserialization in Yii 2","id":"CVE-2020-15148","kev_date_added":null,"published":"2020-09-15"},{"cvss_score":8.1,"headline":"Unsafe Reflection in base Component class in yiisoft/yii2","id":"CVE-2024-4990","kev_date_added":null,"published":"2025-03-20"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["yiisoft"]},"summary":"Attackers can achieve remote code execution if the application unsafely deserializes user input using the Yii framework.","url":"https://insights.sbomify.com/CVE-2022-41922/"}