{"answers":{"affected":"3 open source packages ship an affected version, including tailscale.com. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-41924 exists.","fix":"Upgrade tailscale.com to 1.32.3 or later.","what":"CVE-2022-41924 is a critical vulnerability in tailscale, published on 23 Nov 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-41924 and fix it if it is affected.\n\nWhat it is: CVE-2022-41924 is a critical vulnerability in tailscale, published on 23 Nov 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-41924 exists.\n\nAffected packages and fixed versions:\n- tailscale.com (Go): affected all versions; fixed in 1.32.3\n- tailscale.com (Go): affected all versions; fixed in 1.32.3\n- tailscale.com (Go): affected all versions; fixed in 1.32.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-41924/ (Markdown: https://insights.sbomify.com/CVE-2022-41924/index.md)","id":"CVE-2022-41924","markdown":"https://insights.sbomify.com/CVE-2022-41924/index.md","name":"CVE-2022-41924","record":{"aliases":["GHSA-vqp6-rc3h-83cp","GO-2022-1120"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Tailscale Windows client","requires_auth":"none","summary":"A malicious website can exploit CSRF in the Tailscale Windows client to reconfigure the daemon and achieve remote code execution.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"tailscale","vendor":"tailscale"}],"cvss":{"score":9.6,"severity":"critical","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:L/A:H","version":"3.0"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"},{"id":"CWE-346","name":"Origin Validation Error"}],"description":"A vulnerability identified in the Tailscale Windows client allows a malicious website to reconfigure the Tailscale daemon `tailscaled`, which can then be used to remotely execute code. In the Tailscale Windows client, the local API was bound to a local TCP socket, and communicated with the Windows client GUI in cleartext with no Host header verification. This allowed an attacker-controlled website visited by the node to rebind DNS to an attacker-controlled DNS server, and then make local API requests in the client, including changing the coordination server to an attacker-controlled coordination server. An attacker-controlled coordination server can send malicious URL responses to the client, including pushing executables or installing an SMB share. These allow the attacker to remotely execute code on the node. All Windows clients prior to version v.1.32.3 are affected. If you are running Tailscale on Windows, upgrade to v1.32.3 or later to remediate the issue.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":"2025-01-04","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2025-01-04T16:40:35Z","kind":"github_poc","ref":"https://github.com/oalieno/CVE-2022-41924","stars":0,"title":null}],"tier":"weaponised"},"has_fix":true,"headline":"Tailscale Windows daemon is vulnerable to RCE via CSRF","id":"CVE-2022-41924","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"csrf","year":"2022"},"n_packages":3,"n_references":3,"next":{"headline":"Tailscale daemon is vulnerable to information disclosure via CSRF","id":"CVE-2022-41925"},"packages":[{"ecosystem":"Go","fixed":["1.32.3"],"introduced":["0"],"last_affected":[],"package":"tailscale.com","purl":null,"source":"GHSA-vqp6-rc3h-83cp"},{"ecosystem":"Go","fixed":["1.32.3"],"introduced":["0"],"last_affected":[],"package":"tailscale.com","purl":"pkg:golang/tailscale.com","source":"GHSA-vqp6-rc3h-83cp"},{"ecosystem":"Go","fixed":["1.32.3"],"introduced":["0"],"last_affected":[],"package":"tailscale.com","purl":"pkg:golang/tailscale.com","source":"GO-2022-1120"}],"prev":{"headline":"Grails Spring Security Core plugin vulnerable to privilege escalation","id":"CVE-2022-41923"},"products":["tailscale"],"published":"2022-11-23","related":[{"cvss_score":5.7,"headline":"Non-interactive Tailscale SSH sessions on FreeBSD may use the effective group ID of the tailscaled process","id":"CVE-2023-28436","kev_date_added":null,"published":"2023-03-23"},{"cvss_score":3.8,"headline":"Tailscale daemon is vulnerable to information disclosure via CSRF","id":"CVE-2022-41925","kev_date_added":null,"published":"2022-11-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-22","vendors":["tailscale"]},"summary":"A malicious website can exploit CSRF in the Tailscale Windows client to reconfigure the daemon and achieve remote code execution.","url":"https://insights.sbomify.com/CVE-2022-41924/"}