# CVE-2022-41924: Tailscale Windows daemon is vulnerable to RCE via CSRF

> A malicious website can exploit CSRF in the Tailscale Windows client to reconfigure the daemon and achieve remote code execution.

- **Severity:** Critical 9.6 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Nov 2022
- **Updated:** 22 Apr 2025
- **Also known as:** GHSA-vqp6-rc3h-83cp, GO-2022-1120

## What is CVE-2022-41924?

CVE-2022-41924 is a critical vulnerability in tailscale, published on 23 Nov 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A vulnerability identified in the Tailscale Windows client allows a malicious website to reconfigure the Tailscale daemon `tailscaled`, which can then be used to remotely execute code. In the Tailscale Windows client, the local API was bound to a local TCP socket, and communicated with the Windows client GUI in cleartext with no Host header verification. This allowed an attacker-controlled website visited by the node to rebind DNS to an attacker-controlled DNS server, and then make local API requests in the client, including changing the coordination server to an attacker-controlled coordination server. An attacker-controlled coordination server can send malicious URL responses to the client, including pushing executables or installing an SMB share. These allow the attacker to remotely execute code on the node. All Windows clients prior to version v.1.32.3 are affected. If you are running Tailscale on Windows, upgrade to v1.32.3 or later to remediate the issue.

Weakness: CWE-352 (Cross-Site Request Forgery), CWE-346 (Origin Validation Error)

## Which versions are affected by CVE-2022-41924?

3 open source packages ship an affected version, including tailscale.com. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tailscale.com` | Go | All versions | 1.32.3 |
| `tailscale.com` | Go | All versions | 1.32.3 |
| `tailscale.com` | Go | All versions | 1.32.3 |

Products: Tailscale Tailscale.

## How do I fix CVE-2022-41924?

Upgrade tailscale.com to 1.32.3 or later.

## Is CVE-2022-41924 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-41924 exists.

Public exploit code:

- https://github.com/oalieno/CVE-2022-41924 (github_poc): https://github.com/oalieno/CVE-2022-41924

## Other vulnerabilities in tailscale

- [CVE-2023-28436](https://insights.sbomify.com/CVE-2023-28436/): Non-interactive Tailscale SSH sessions on FreeBSD may use the effective group ID of the tailscaled process (medium 5.7)
- [CVE-2022-41925](https://insights.sbomify.com/CVE-2022-41925/): Tailscale daemon is vulnerable to information disclosure via CSRF (low 3.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-41924 and fix it if it is affected.

What it is: CVE-2022-41924 is a critical vulnerability in tailscale, published on 23 Nov 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-41924 exists.

Affected packages and fixed versions:
- tailscale.com (Go): affected all versions; fixed in 1.32.3
- tailscale.com (Go): affected all versions; fixed in 1.32.3
- tailscale.com (Go): affected all versions; fixed in 1.32.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-41924/ (Markdown: https://insights.sbomify.com/CVE-2022-41924/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-41924
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-41924
- OSV: https://osv.dev/vulnerability/CVE-2022-41924

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-41924/
Summaries are generated and may contain mistakes; the official description above is the record.
