# CVE-2022-41925: Tailscale daemon is vulnerable to information disclosure via CSRF

> Attackers can use DNS rebinding to access the peer API, reading environment variables and potentially hijacking the tailnet.

- **Severity:** Low 3.8 (`CVSS:3.0/AV:A/AC:L/PR:N/UI:R/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Nov 2022
- **Updated:** 22 Apr 2025
- **Also known as:** GHSA-qccm-wmcq-pwr6, GO-2022-1119

## What is CVE-2022-41925?

CVE-2022-41925 is a low-severity vulnerability in tailscale, published on 23 Nov 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

A vulnerability identified in the Tailscale client allows a malicious website to access the peer API, which can then be used to access Tailscale environment variables. In the Tailscale client, the peer API was vulnerable to DNS rebinding. This allowed an attacker-controlled website visited by the node to rebind DNS for the peer API to an attacker-controlled DNS server, and then making peer API requests in the client, including accessing the node’s Tailscale environment variables. An attacker with access to the peer API on a node could use that access to read the node’s environment variables, including any credentials or secrets stored in environment variables. This may include Tailscale authentication keys, which could then be used to add new nodes to the user’s tailnet. The peer API access could also be used to learn of other nodes in the tailnet or send files via Taildrop. All Tailscale clients prior to version v1.32.3 are affected. Upgrade to v1.32.3 or later to remediate the issue.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2022-41925?

3 open source packages ship an affected version, including tailscale.com/cmd and tailscale.com. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tailscale.com/cmd` | Go | All versions | 1.32.3 |
| `tailscale.com/cmd` | Go | All versions | 1.32.3 |
| `tailscale.com` | Go | All versions | 1.32.3 |

Products: Tailscale Tailscale.

## How do I fix CVE-2022-41925?

Upgrade tailscale.com/cmd to 1.32.3 or later.

## Is CVE-2022-41925 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-41925 exists.

## Other vulnerabilities in tailscale

- [CVE-2022-41924](https://insights.sbomify.com/CVE-2022-41924/): Tailscale Windows daemon is vulnerable to RCE via CSRF (critical 9.6)
- [CVE-2023-28436](https://insights.sbomify.com/CVE-2023-28436/): Non-interactive Tailscale SSH sessions on FreeBSD may use the effective group ID of the tailscaled process (medium 5.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-41925 and fix it if it is affected.

What it is: CVE-2022-41925 is a low-severity vulnerability in tailscale, published on 23 Nov 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-41925 exists.

Affected packages and fixed versions:
- tailscale.com/cmd (Go): affected all versions; fixed in 1.32.3
- tailscale.com/cmd (Go): affected all versions; fixed in 1.32.3
- tailscale.com (Go): affected all versions; fixed in 1.32.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-41925/ (Markdown: https://insights.sbomify.com/CVE-2022-41925/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-41925
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-41925
- OSV: https://osv.dev/vulnerability/CVE-2022-41925

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-41925/
Summaries are generated and may contain mistakes; the official description above is the record.
