# CVE-2022-41927: XWiki Platform vulnerable to Cross-Site Request Forgery (CSRF) allowing to delete or rename tags

> Attackers can trick users into deleting or renaming tags in XWiki Platform without confirmation, requiring a patch to fix.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Nov 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-mq7h-5574-hw9f

## What is CVE-2022-41927?

CVE-2022-41927 is a high-severity vulnerability in Xwiki Xwiki, published on 23 Nov 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

XWiki Platform is vulnerable to Cross-Site Request Forgery (CSRF) that may allow attackers to delete or rename tags without needing any confirmation. The problem has been patched in XWiki 13.10.7, 14.4.1 and 14.5RC1. Workarounds: It's possible to patch existing instances directly by editing the page Main.Tags and add this kind of check, in the code for renaming and for deleting: ``` #if (!$services.csrf.isTokenValid($request.get('form_token'))) #set ($discard = $response.sendError(401, "Wrong CSRF token")) #end ```

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2022-41927?

4 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-tag-ui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-tag-ui` | Maven | From 14.0.0 | 14.4.1 |
| `org.xwiki.platform:xwiki-platform-tag-ui` | Maven | From 14.0.0 | 14.4.1 |
| `org.xwiki.platform:xwiki-platform-tag-ui` | Maven | From 3.2-milestone-2 | 13.10.7 |
| `org.xwiki.platform:xwiki-platform-tag-ui` | Maven | From 3.2-milestone-2 | 13.10.7 |

Products: Xwiki Xwiki.

## How do I fix CVE-2022-41927?

Upgrade org.xwiki.platform:xwiki-platform-tag-ui to a fixed version for your release line: 14.4.1 or 13.10.7.

## Is CVE-2022-41927 being exploited?

There is no known exploitation of CVE-2022-41927 in the wild and no public exploit code.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-41927 and fix it if it is affected.

What it is: CVE-2022-41927 is a high-severity vulnerability in Xwiki Xwiki, published on 23 Nov 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-41927 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-tag-ui (Maven): affected from 14.0.0; fixed in 14.4.1
- org.xwiki.platform:xwiki-platform-tag-ui (Maven): affected from 14.0.0; fixed in 14.4.1
- org.xwiki.platform:xwiki-platform-tag-ui (Maven): affected from 3.2-milestone-2; fixed in 13.10.7
- org.xwiki.platform:xwiki-platform-tag-ui (Maven): affected from 3.2-milestone-2; fixed in 13.10.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-41927/ (Markdown: https://insights.sbomify.com/CVE-2022-41927/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-41927
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-41927
- OSV: https://osv.dev/vulnerability/CVE-2022-41927

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-41927/
Summaries are generated and may contain mistakes; the official description above is the record.
