CVE-2022-41928 Improper Neutralization of Directives in Dynamically Evaluated Code ('Eval Injection') in AttachmentSelector.xml
Attackers can execute arbitrary code via eval injection in AttachmentSelector.xml, requiring an upgrade to patched XWiki versions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-41928?
CVE-2022-41928 is a critical code injection vulnerability in Xwiki Xwiki, published on 23 Nov 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
XWiki Platform vulnerable to Improper Neutralization of Directives in Dynamically Evaluated Code ('Eval Injection') in AttachmentSelector.xml. The issue can also be reproduced by inserting the dangerous payload in the `height` or `alt` macro properties. This has been patched in versions 13.10.7, 14.4.2, and 14.5. The issue can be fixed on a running wiki by updating `XWiki.AttachmentSelector` with the versions below: - 14.5-rc-1+: https://github.com/xwiki/xwiki-platform/commit/eb15147adf94bddb92626f862c1710d45bcd64a7#diff-e1513599ab698991f6cbba55d38f3f464432ced8d137a668b1f7618c7e747e23 - 14.4.2+: https://github.com/xwiki/xwiki-platform/commit/c02f8eb1f3c953d124f2c097021536f8bc00fa8d#diff-e1513599ab698991f6cbba55d38f3f464432ced8d137a668b1f7618c7e747e23 - 13.10.7+: https://github.com/xwiki/xwiki-platform/commit/efd0df0468d46149ba68b66660b93f31b6318515#diff-e1513599ab698991f6cbba55d38f3f464432ced8d137a668b1f7618c7e747e23
Weakness: CWE-95
Which versions are affected by CVE-2022-41928?
4 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-attachment-ui. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.xwiki.platform:xwiki-platform-attachment-ui Maven | From 14.0.0 | 14.4.2 |
org.xwiki.platform:xwiki-platform-attachment-ui Maven | From 14.0.0 | 14.4.2 |
org.xwiki.platform:xwiki-platform-attachment-ui Maven | From 5.0-milestone-1 | 13.10.7 |
org.xwiki.platform:xwiki-platform-attachment-ui Maven | From 5.0-milestone-1 | 13.10.7 |
Products include Xwiki Xwiki.
How do I fix CVE-2022-41928?
Upgrade org.xwiki.platform:xwiki-platform-attachment-ui to a fixed version for your release line: 14.4.2 or 13.10.7.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2022-41928 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-41928 exists.
Other vulnerabilities in Xwiki Xwiki
- CVE-2025-24893 XWiki Platform Eval Injection
- CVE-2025-53836 XWiki Rendering is vulnerable to RCE attacks when processing nested macros
- CVE-2024-55662 XWiki allows remote code execution through the extension sheet
- CVE-2024-55877 XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList
- CVE-2024-37901 XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet
Sources
Also known as GHSA-9hqh-fmhg-vq2j.