# CVE-2022-41928: Improper Neutralization of Directives in Dynamically Evaluated Code ('Eval Injection') in AttachmentSelector.xml

> Attackers can execute arbitrary code via eval injection in AttachmentSelector.xml, requiring an upgrade to patched XWiki versions.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Nov 2022
- **Updated:** 22 Apr 2025
- **Also known as:** GHSA-9hqh-fmhg-vq2j

## What is CVE-2022-41928?

CVE-2022-41928 is a critical code injection vulnerability in Xwiki Xwiki, published on 23 Nov 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

XWiki Platform vulnerable to Improper Neutralization of Directives in Dynamically Evaluated Code ('Eval Injection') in AttachmentSelector.xml. The issue can also be reproduced by inserting the dangerous payload in the `height` or `alt` macro properties. This has been patched in versions 13.10.7, 14.4.2, and 14.5. The issue can be fixed on a running wiki by updating `XWiki.AttachmentSelector` with the versions below: - 14.5-rc-1+: https://github.com/xwiki/xwiki-platform/commit/eb15147adf94bddb92626f862c1710d45bcd64a7#diff-e1513599ab698991f6cbba55d38f3f464432ced8d137a668b1f7618c7e747e23 - 14.4.2+: https://github.com/xwiki/xwiki-platform/commit/c02f8eb1f3c953d124f2c097021536f8bc00fa8d#diff-e1513599ab698991f6cbba55d38f3f464432ced8d137a668b1f7618c7e747e23 - 13.10.7+: https://github.com/xwiki/xwiki-platform/commit/efd0df0468d46149ba68b66660b93f31b6318515#diff-e1513599ab698991f6cbba55d38f3f464432ced8d137a668b1f7618c7e747e23

Weakness: CWE-95 (Improper Neutralization of Directives in Dynamically Evaluated Code)

## Which versions are affected by CVE-2022-41928?

4 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-attachment-ui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-attachment-ui` | Maven | From 14.0.0 | 14.4.2 |
| `org.xwiki.platform:xwiki-platform-attachment-ui` | Maven | From 14.0.0 | 14.4.2 |
| `org.xwiki.platform:xwiki-platform-attachment-ui` | Maven | From 5.0-milestone-1 | 13.10.7 |
| `org.xwiki.platform:xwiki-platform-attachment-ui` | Maven | From 5.0-milestone-1 | 13.10.7 |

Products: Xwiki Xwiki.

## How do I fix CVE-2022-41928?

Upgrade org.xwiki.platform:xwiki-platform-attachment-ui to a fixed version for your release line: 14.4.2 or 13.10.7.

## Is CVE-2022-41928 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-41928 exists.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-41928 and fix it if it is affected.

What it is: CVE-2022-41928 is a critical code injection vulnerability in Xwiki Xwiki, published on 23 Nov 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-41928 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-attachment-ui (Maven): affected from 14.0.0; fixed in 14.4.2
- org.xwiki.platform:xwiki-platform-attachment-ui (Maven): affected from 14.0.0; fixed in 14.4.2
- org.xwiki.platform:xwiki-platform-attachment-ui (Maven): affected from 5.0-milestone-1; fixed in 13.10.7
- org.xwiki.platform:xwiki-platform-attachment-ui (Maven): affected from 5.0-milestone-1; fixed in 13.10.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-41928/ (Markdown: https://insights.sbomify.com/CVE-2022-41928/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-41928
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-41928
- OSV: https://osv.dev/vulnerability/CVE-2022-41928

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-41928/
Summaries are generated and may contain mistakes; the official description above is the record.
