# CVE-2022-41929: Missing Authorization in User#setDisabledStatus in org.xwiki.platform:xwiki-platform-oldcore

> Users with Script rights can improperly enable or disable other users, bypassing admin-only restrictions in XWiki.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Nov 2022
- **Updated:** 22 Apr 2025
- **Also known as:** GHSA-2gj2-vj98-j2qq

## What is CVE-2022-41929?

CVE-2022-41929 is a medium-severity missing authorization vulnerability in Xwiki Xwiki, published on 23 Nov 2022. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

org.xwiki.platform:xwiki-platform-oldcore is missing authorization in User#setDisabledStatus, which may allow an incorrectly authorized user with only Script rights to enable or disable a user. This operation is meant to only be available for users with admin rights. This problem has been patched in XWiki 13.10.7, 14.4.2 and 14.5RC1.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2022-41929?

4 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-oldcore. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 11.7RC1 | 13.10.7 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 11.7RC1 | 13.10.7 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 14.0.0 | 14.4.2 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 14.0.0 | 14.4.2 |

Products: Xwiki Xwiki.

## How do I fix CVE-2022-41929?

Upgrade org.xwiki.platform:xwiki-platform-oldcore to a fixed version for your release line: 13.10.7 or 14.4.2.

## Is CVE-2022-41929 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-41929 exists.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-41929 and fix it if it is affected.

What it is: CVE-2022-41929 is a medium-severity missing authorization vulnerability in Xwiki Xwiki, published on 23 Nov 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-41929 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 11.7RC1; fixed in 13.10.7
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 11.7RC1; fixed in 13.10.7
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 14.0.0; fixed in 14.4.2
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 14.0.0; fixed in 14.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-41929/ (Markdown: https://insights.sbomify.com/CVE-2022-41929/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-41929
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-41929
- OSV: https://osv.dev/vulnerability/CVE-2022-41929

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-41929/
Summaries are generated and may contain mistakes; the official description above is the record.
