# CVE-2022-41932: Creation of new database tables through login form on PostgreSQL

> Attackers can degrade database performance by creating excessive schemas and tables via the login form, requiring an upgrade to XWiki.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Nov 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-4x5r-6v26-7j4v

## What is CVE-2022-41932?

CVE-2022-41932 is a high-severity denial of service vulnerability in Xwiki Xwiki, published on 23 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. It's possible to make XWiki create many new schemas and fill them with tables just by using a crafted user identifier in the login form. This may lead to degraded database performance. The problem has been patched in XWiki 13.10.8, 14.6RC1 and 14.4.2. Users are advised to upgrade. There are no known workarounds for this issue.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2022-41932?

6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-oldcore. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | All versions | 13.10.8 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | All versions | 13.10.8 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 14.0.0 | 14.4.2 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 14.0.0 | 14.4.2 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 14.5.0 | 14.6-rc-1 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 14.5.0 | 14.6-rc-1 |

Products: Xwiki Xwiki.

## How do I fix CVE-2022-41932?

Upgrade org.xwiki.platform:xwiki-platform-oldcore to a fixed version for your release line: 13.10.8, 14.4.2 or 14.6-rc-1.

## Is CVE-2022-41932 being exploited?

There is no known exploitation of CVE-2022-41932 in the wild and no public exploit code.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-41932 and fix it if it is affected.

What it is: CVE-2022-41932 is a high-severity denial of service vulnerability in Xwiki Xwiki, published on 23 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-41932 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected all versions; fixed in 13.10.8
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected all versions; fixed in 13.10.8
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 14.0.0; fixed in 14.4.2
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 14.0.0; fixed in 14.4.2
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 14.5.0; fixed in 14.6-rc-1
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 14.5.0; fixed in 14.6-rc-1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-41932/ (Markdown: https://insights.sbomify.com/CVE-2022-41932/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-41932
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-41932
- OSV: https://osv.dev/vulnerability/CVE-2022-41932

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-41932/
Summaries are generated and may contain mistakes; the official description above is the record.
