# CVE-2022-41933: Plaintext storage of password in org.xwiki.platform:xwiki-platform-security-authentication-default

> Attackers with database access can read plaintext passwords of users who used the forgotten password feature in XWiki.

- **Severity:** Medium 6.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Nov 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-q2hm-2h45-v5g3

## What is CVE-2022-41933?

CVE-2022-41933 is a medium-severity vulnerability in Xwiki Xwiki, published on 23 Nov 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. When the `reset a forgotten password` feature of XWiki was used, the password was then stored in plain text in database. This only concerns XWiki 13.1RC1 and newer versions. Note that it only concerns the reset password feature available from the "Forgot your password" link in the login view: the features allowing a user to change their password, or for an admin to change a user password are not impacted. This vulnerability is particularly dangerous in combination with other vulnerabilities allowing to perform data leak of personal data from users, such as GHSA-599v-w48h-rjrm. Note that this vulnerability only concerns the users of the main wiki: in case of farms, the users registered on subwiki are not impacted thanks to a bug we discovered when investigating this. The problem has been patched in version 14.6RC1, 14.4.3 and 13.10.8. The patch involves a migration of the impacted users as well as the history of the page, to ensure no password remains in plain text in the database. This migration also involves to inform the users about the possible disclosure of their passwords: by default, two emails are automatically sent to the impacted users. A first email to inform about the possibility that their password have been leaked, and a second email using the reset password feature to ask them to set a new password. It's also possible for administrators to set some properties for the migration: it's possible to decide if the user password should be reset (default) or if the passwords should be kept but only hashed. Note that in the first option, the users won't be able to login anymore until they set a new password if they were impacted. Note that in both options, mails will be sent to users to inform them and encourage them to change their passwords.

Weakness: CWE-522 (Insufficiently Protected Credentials), CWE-312 (Cleartext Storage of Sensitive Information)

## Which versions are affected by CVE-2022-41933?

4 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-security-authentication-default. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-security-authentication-default` | Maven | From 13.1RC1 | 13.10.8 |
| `org.xwiki.platform:xwiki-platform-security-authentication-default` | Maven | From 13.1RC1 | 13.10.8 |
| `org.xwiki.platform:xwiki-platform-security-authentication-default` | Maven | From 14.0.0 | 14.4.3 |
| `org.xwiki.platform:xwiki-platform-security-authentication-default` | Maven | From 14.0.0 | 14.4.3 |

Products: Xwiki Xwiki.

## How do I fix CVE-2022-41933?

Upgrade org.xwiki.platform:xwiki-platform-security-authentication-default to a fixed version for your release line: 13.10.8 or 14.4.3.

## Is CVE-2022-41933 being exploited?

There is no known exploitation of CVE-2022-41933 in the wild and no public exploit code.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-41933 and fix it if it is affected.

What it is: CVE-2022-41933 is a medium-severity vulnerability in Xwiki Xwiki, published on 23 Nov 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-41933 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-security-authentication-default (Maven): affected from 13.1RC1; fixed in 13.10.8
- org.xwiki.platform:xwiki-platform-security-authentication-default (Maven): affected from 13.1RC1; fixed in 13.10.8
- org.xwiki.platform:xwiki-platform-security-authentication-default (Maven): affected from 14.0.0; fixed in 14.4.3
- org.xwiki.platform:xwiki-platform-security-authentication-default (Maven): affected from 14.0.0; fixed in 14.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-41933/ (Markdown: https://insights.sbomify.com/CVE-2022-41933/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-41933
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-41933
- OSV: https://osv.dev/vulnerability/CVE-2022-41933

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-41933/
Summaries are generated and may contain mistakes; the official description above is the record.
