# CVE-2022-41934: Improper Neutralization of Directives in Dynamically Evaluated Code in org.xwiki.platform:xwiki-platform-menu-ui

> Authenticated users can execute arbitrary code via the menu macro, leading to full system compromise.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Nov 2022
- **Updated:** 22 Apr 2025
- **Also known as:** GHSA-6w8h-26xx-cf8q

## What is CVE-2022-41934?

CVE-2022-41934 is a critical code injection vulnerability in Xwiki Xwiki, published on 23 Nov 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. Any user with view rights on commonly accessible documents including the menu macro can execute arbitrary Groovy, Python or Velocity code in XWiki leading to full access to the XWiki installation due to improper escaping of the macro content and parameters of the menu macro. The problem has been patched in XWiki 14.6RC1, 13.10.8 and 14.4.3. The patch (commit `2fc20891`) for the document `Menu.MenuMacro` can be manually applied or a XAR archive of a patched version can be imported. The menu macro was basically unchanged since XWiki 11.6 so on XWiki 11.6 or later the patch for version of 13.10.8 (commit `59ccca24a`) can most likely be applied, on XWiki version 14.0 and later the versions in XWiki 14.6 and 14.4.3 should be appropriate.

Weakness: CWE-116 (Improper Encoding or Escaping of Output), CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2022-41934?

4 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-menu-ui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-menu-ui` | Maven | All versions | 13.10.8 |
| `org.xwiki.platform:xwiki-platform-menu-ui` | Maven | All versions | 13.10.8 |
| `org.xwiki.platform:xwiki-platform-menu-ui` | Maven | From 14.0.0 | 14.4.3 |
| `org.xwiki.platform:xwiki-platform-menu-ui` | Maven | From 14.0.0 | 14.4.3 |

Products: Xwiki Xwiki.

## How do I fix CVE-2022-41934?

Upgrade org.xwiki.platform:xwiki-platform-menu-ui to a fixed version for your release line: 13.10.8 or 14.4.3.

## Is CVE-2022-41934 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-41934 exists.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-41934 and fix it if it is affected.

What it is: CVE-2022-41934 is a critical code injection vulnerability in Xwiki Xwiki, published on 23 Nov 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-41934 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-menu-ui (Maven): affected all versions; fixed in 13.10.8
- org.xwiki.platform:xwiki-platform-menu-ui (Maven): affected all versions; fixed in 13.10.8
- org.xwiki.platform:xwiki-platform-menu-ui (Maven): affected from 14.0.0; fixed in 14.4.3
- org.xwiki.platform:xwiki-platform-menu-ui (Maven): affected from 14.0.0; fixed in 14.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-41934/ (Markdown: https://insights.sbomify.com/CVE-2022-41934/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-41934
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-41934
- OSV: https://osv.dev/vulnerability/CVE-2022-41934

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-41934/
Summaries are generated and may contain mistakes; the official description above is the record.
