# CVE-2022-41935: Exposure of Sensitive Information to an Unauthorized Actor in org.xwiki.platform:xwiki-platform-livetable-ui

> Unauthorized users can deduce the existence of hidden documents via Livetable queries, requiring a patch to prevent information leakage.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Nov 2022
- **Updated:** 22 Apr 2025
- **Also known as:** GHSA-p2x4-6ghr-6vmq

## What is CVE-2022-41935?

CVE-2022-41935 is a medium-severity vulnerability in Xwiki Xwiki, published on 23 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. Users without the right to view documents can deduce their existence by repeated Livetable queries. The issue has been patched in XWiki 14.6RC1, 13.10.8, and 14.4.3, the response is not properly cleaned up of obfuscated entries. As a workaround, The patch for the document `XWiki.LiveTableResultsMacros` can be manually applied or a XAR archive of a patched version can be imported, on versions 12.10.11, 13.9-rc-1, and 13.4.4. There are no known workarounds for this issue.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2022-41935?

6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-livetable-ui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-livetable-ui` | Maven | From 12.10.11 | 13.10.8 |
| `org.xwiki.platform:xwiki-platform-livetable-ui` | Maven | From 12.10.11 | 13.10.8 |
| `org.xwiki.platform:xwiki-platform-livetable-ui` | Maven | From 14.0.0 | 14.4.3 |
| `org.xwiki.platform:xwiki-platform-livetable-ui` | Maven | From 14.0.0 | 14.4.3 |
| `org.xwiki.platform:xwiki-platform-livetable-ui` | Maven | From 14.5.0 | 14.6-rc-1 |
| `org.xwiki.platform:xwiki-platform-livetable-ui` | Maven | From 14.5.0 | 14.6-rc-1 |

Products: Xwiki Xwiki.

## How do I fix CVE-2022-41935?

Upgrade org.xwiki.platform:xwiki-platform-livetable-ui to a fixed version for your release line: 13.10.8, 14.4.3 or 14.6-rc-1.

## Is CVE-2022-41935 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-41935 exists.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-41935 and fix it if it is affected.

What it is: CVE-2022-41935 is a medium-severity vulnerability in Xwiki Xwiki, published on 23 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-41935 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-livetable-ui (Maven): affected from 12.10.11; fixed in 13.10.8
- org.xwiki.platform:xwiki-platform-livetable-ui (Maven): affected from 12.10.11; fixed in 13.10.8
- org.xwiki.platform:xwiki-platform-livetable-ui (Maven): affected from 14.0.0; fixed in 14.4.3
- org.xwiki.platform:xwiki-platform-livetable-ui (Maven): affected from 14.0.0; fixed in 14.4.3
- org.xwiki.platform:xwiki-platform-livetable-ui (Maven): affected from 14.5.0; fixed in 14.6-rc-1
- org.xwiki.platform:xwiki-platform-livetable-ui (Maven): affected from 14.5.0; fixed in 14.6-rc-1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-41935/ (Markdown: https://insights.sbomify.com/CVE-2022-41935/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-41935
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-41935
- OSV: https://osv.dev/vulnerability/CVE-2022-41935

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-41935/
Summaries are generated and may contain mistakes; the official description above is the record.
