CVE-2022-41938 Cross site scripting vulnerability with discussion titles in flarum
Attackers can inject malicious HTML via discussion titles, leading to cross-site scripting when visitors view the page.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-41938?
CVE-2022-41938 is a critical cross-site scripting vulnerability in flarum framework, published on 19 Nov 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Flarum is an open source discussion platform. Flarum's page title system allowed for page titles to be converted into HTML DOM nodes when pages were rendered. The change was made after `v1.5` and was not noticed. This allowed an attacker to inject malicious HTML markup using a discussion title input, either by creating a new discussion or renaming one. The XSS attack occurs after a visitor opens the relevant discussion page. All communities running Flarum from `v1.5.0` to `v1.6.1` are impacted. The vulnerability has been fixed and published as flarum/core `v1.6.2`. All communities running Flarum from `v1.5.0` to `v1.6.1` have to upgrade as soon as possible to v1.6.2. There are no known workarounds for this issue.
Weakness: CWE-79
Which versions are affected by CVE-2022-41938?
2 open source packages ship an affected version, including flarum/core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
flarum/core Packagist | From 1.5.0 | 1.6.2 |
flarum/core Packagist | From 1.5.0 | 1.6.2 |
Products include Flarum Flarum.
How do I fix CVE-2022-41938?
Upgrade flarum/core to 1.6.2 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2022-41938 being exploited?
There is no known exploitation of CVE-2022-41938 in the wild and no public exploit code.
Other vulnerabilities in flarum framework
- CVE-2021-32671 XSS vulnerability with translator
- CVE-2019-13183 Cross-site request forgery in n/a
- CVE-2023-22487 Post mentions can be used to read any post on the forum without access control
- CVE-2019-11514 Flarum mishandles invalidation of user email tokens
- CVE-2023-40033 Server-Side Request Forgery via Avatar upload in flarum
Sources
Also known as GHSA-7x4w-j98p-854x.