{"answers":{"affected":"2 open source packages ship an affected version, including flarum/core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-41938 in the wild and no public exploit code.","fix":"Upgrade flarum/core to 1.6.2 or later.","what":"CVE-2022-41938 is a critical cross-site scripting vulnerability in flarum framework, published on 19 Nov 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-41938 and fix it if it is affected.\n\nWhat it is: CVE-2022-41938 is a critical cross-site scripting vulnerability in flarum framework, published on 19 Nov 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-41938 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- flarum/core (Packagist): affected from 1.5.0; fixed in 1.6.2\n- flarum/core (Packagist): affected from 1.5.0; fixed in 1.6.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-41938/ (Markdown: https://insights.sbomify.com/CVE-2022-41938/index.md)","id":"CVE-2022-41938","markdown":"https://insights.sbomify.com/CVE-2022-41938/index.md","name":"CVE-2022-41938","record":{"aliases":["GHSA-7x4w-j98p-854x"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Flarum discussion platform","requires_auth":"low_privilege","summary":"Attackers can inject malicious HTML via discussion titles, leading to cross-site scripting when visitors view the page.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"flarum","vendor":"flarum"}],"cvss":{"score":9,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Flarum is an open source discussion platform. Flarum's page title system allowed for page titles to be converted into HTML DOM nodes when pages were rendered. The change was made after `v1.5` and was not noticed. This allowed an attacker to inject malicious HTML markup using a discussion title input, either by creating a new discussion or renaming one. The XSS attack occurs after a visitor opens the relevant discussion page. All communities running Flarum from `v1.5.0` to `v1.6.1` are impacted. The vulnerability has been fixed and published as flarum/core `v1.6.2`. All communities running Flarum from `v1.5.0` to `v1.6.1` have to upgrade as soon as possible to v1.6.2. There are no known workarounds for this issue.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross site scripting vulnerability with discussion titles in flarum","id":"CVE-2022-41938","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"Credential exposure when running third-party builders in knative/func","id":"CVE-2022-41939"},"packages":[{"ecosystem":"Packagist","fixed":["1.6.2"],"introduced":["1.5.0"],"last_affected":[],"package":"flarum/core","purl":null,"source":"GHSA-7x4w-j98p-854x"},{"ecosystem":"Packagist","fixed":["1.6.2"],"introduced":["1.5.0"],"last_affected":[],"package":"flarum/core","purl":"pkg:composer/flarum/core","source":"GHSA-7x4w-j98p-854x"}],"prev":{"headline":"Missing Authorization in XWiki Platform","id":"CVE-2022-41937"},"products":["framework"],"published":"2022-11-19","related":[{"cvss_score":10,"headline":"XSS vulnerability with translator","id":"CVE-2021-32671","kev_date_added":null,"published":"2021-06-07"},{"cvss_score":8.8,"headline":"Cross-site request forgery in n/a","id":"CVE-2019-13183","kev_date_added":null,"published":"2019-07-07"},{"cvss_score":7.7,"headline":"Post mentions can be used to read any post on the forum without access control","id":"CVE-2023-22487","kev_date_added":null,"published":"2023-01-11"},{"cvss_score":7.5,"headline":"Flarum mishandles invalidation of user email tokens","id":"CVE-2019-11514","kev_date_added":null,"published":"2019-04-25"},{"cvss_score":7.1,"headline":"Server-Side Request Forgery via Avatar upload in flarum","id":"CVE-2023-40033","kev_date_added":null,"published":"2023-08-16"},{"cvss_score":6.8,"headline":"Flarum Vulnerable to Session Hijacking via Authoritative Subdomain Cookie Overwrite","id":"CVE-2025-27794","kev_date_added":null,"published":"2025-03-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["flarum"]},"summary":"Attackers can inject malicious HTML via discussion titles, leading to cross-site scripting when visitors view the page.","url":"https://insights.sbomify.com/CVE-2022-41938/"}