CVE-2022-41941 glpi contains XSS Stored inside Standard Interface Help Link href attribute

Medium 6.2 Published Updated

An administrator can inject malicious scripts into help links, leading to stored XSS attacks against other users.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2022-41941?

CVE-2022-41941 is a medium-severity cross-site scripting vulnerability in Glpi-Project Glpi, published on 25 Jan 2023. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

GLPI is a Free Asset and IT Management Software package. Versions 10.0.0 and above, prior to 10.0.6, are subject to Cross-site Scripting. An administrator may store malicious code in help links. This issue is patched in 10.0.6.

Weakness: CWE-79

Which versions are affected by CVE-2022-41941?

It affects 1 product.

Products include Glpi-Project Glpi.

How do I fix CVE-2022-41941?

No fix has been published for CVE-2022-41941 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2022-41941 being exploited?

There is no known exploitation of CVE-2022-41941 in the wild and no public exploit code.

All Glpi-Project Glpi vulnerabilities

Sources

Also known as GHSA-qqqm-7h6v-7cf4, UBUNTU-CVE-2022-41941.

Is CVE-2022-41941 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free