CVE-2022-41944 Discourse users can see notifications for topics they no longer have access to

Low 3.5 Published Updated

Attackers can view notifications for restricted topics, potentially exposing sensitive information in topic titles to unauthorized users.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2022-41944?

CVE-2022-41944 is a low-severity vulnerability in Discourse Discourse, published on 28 Nov 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Discourse is an open-source discussion platform. In stable versions prior to 2.8.12 and beta or tests-passed versions prior to 2.9.0.beta.13, under certain conditions, a user can see notifications for topics they no longer have access to. If there is sensitive information in the topic title, it will therefore have been exposed. This issue is patched in stable version 2.8.12, beta version 2.9.0.beta13, and tests-passed version 2.9.0.beta13. There are no workarounds available.

Weakness: CWE-863, CWE-200

Which versions are affected by CVE-2022-41944?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiAll versions2.8.12

Products include Discourse Discourse.

How do I fix CVE-2022-41944?

Upgrade discourse to 2.8.12 or later.

Is CVE-2022-41944 being exploited?

There is no known exploitation of CVE-2022-41944 in the wild and no public exploit code.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2022-41944, GHSA-354r-jpj5-53c2.

Is CVE-2022-41944 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free