# CVE-2022-41952: Uncontrolled Resource Consumption in Matrix Synapse

> Attackers can cause excessive resource consumption and long-lived connections by posting streaming media URLs to large rooms, impacting Matrix Synapse servers.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Nov 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-4822-jvwx-w47h, PYSEC-2026-663, UBUNTU-CVE-2022-41952

## What is CVE-2022-41952?

CVE-2022-41952 is a medium-severity denial of service vulnerability in matrix-org synapse, published on 22 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Synapse before 1.52.0 with URL preview functionality enabled will attempt to generate URL previews for media stream URLs without properly limiting connection time. Connections will only be terminated after `max_spider_size` (default: 10M) bytes have been downloaded, which can in some cases lead to long-lived connections towards the streaming media server (for instance, Icecast). This can cause excessive traffic and connections toward such servers if their stream URL is, for example, posted to a large room with many Synapse instances with URL preview enabled. Version 1.52.0 implements a timeout mechanism which will terminate URL preview connections after 30 seconds. Since generating URL previews for media streams is not supported and always fails, 1.53.0 additionally implements an allow list for content types for which Synapse will even attempt to generate a URL preview. Upgrade to 1.53.0 to fully resolve the issue. As a workaround, turn off URL preview functionality by setting `url_preview_enabled: false` in the Synapse configuration file.

Weakness: CWE-772 (Missing Release of Resource after Effective Lifetime), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2022-41952?

3 open source packages ship an affected version, including matrix-synapse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `matrix-synapse` | PyPI | All versions | 1.53.0 |
| `matrix-synapse` | PyPI | All versions | 1.53.0 |
| `matrix-synapse` | PyPI | All versions | 1.53.0 |

Products: Matrix Synapse.

## How do I fix CVE-2022-41952?

Upgrade matrix-synapse to 1.53.0 or later.

## Is CVE-2022-41952 being exploited?

There is no known exploitation of CVE-2022-41952 in the wild and no public exploit code.

## Other vulnerabilities in matrix-org synapse

- [CVE-2019-18835](https://insights.sbomify.com/CVE-2019-18835/): Improper Verification of Cryptographic Signature in matrix-synapse (critical 9.8)
- [CVE-2024-52815](https://insights.sbomify.com/CVE-2024-52815/): Synapse allows a a malformed invite to break the invitee's `/sync` (high 8.7)
- [CVE-2024-52805](https://insights.sbomify.com/CVE-2024-52805/): Synapse allows unsupported content types to lead to memory exhaustion (high 8.2)
- [CVE-2024-53863](https://insights.sbomify.com/CVE-2024-53863/): Synapse can be forced to thumbnail unexpected file formats, invoking external, potentially untrustworthy decoders (high 8.2)
- [CVE-2024-37302](https://insights.sbomify.com/CVE-2024-37302/): Synapse denial of service through media disk space consumption (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-41952 and fix it if it is affected.

What it is: CVE-2022-41952 is a medium-severity denial of service vulnerability in matrix-org synapse, published on 22 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-41952 in the wild and no public exploit code.

Affected packages and fixed versions:
- matrix-synapse (PyPI): affected all versions; fixed in 1.53.0
- matrix-synapse (PyPI): affected all versions; fixed in 1.53.0
- matrix-synapse (PyPI): affected all versions; fixed in 1.53.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-41952/ (Markdown: https://insights.sbomify.com/CVE-2022-41952/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-41952
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-41952
- OSV: https://osv.dev/vulnerability/CVE-2022-41952

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-41952/
Summaries are generated and may contain mistakes; the official description above is the record.
