{"answers":{"affected":"6 open source packages ship an affected version, including muhammara and hummus. It affects 2 products.","exploited":"There is no known exploitation of CVE-2022-41957 in the wild and no public exploit code.","fix":"Upgrade muhammara to a fixed version for your release line: 2.6.2 or 3.4.0.","what":"CVE-2022-41957 is a high-severity vulnerability in julianhille MuhammaraJS, published on 28 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-41957 and fix it if it is affected.\n\nWhat it is: CVE-2022-41957 is a high-severity vulnerability in julianhille MuhammaraJS, published on 28 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-41957 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- muhammara (npm): affected all versions; fixed in 2.6.2\n- muhammara (npm): affected all versions; fixed in 2.6.2\n- muhammara (npm): affected from 3.0.0; fixed in 3.4.0\n- muhammara (npm): affected from 3.0.0; fixed in 3.4.0\n- hummus (npm): affected all versions; no fix listed\n- hummus (npm): affected all versions; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-41957/ (Markdown: https://insights.sbomify.com/CVE-2022-41957/index.md)","id":"CVE-2022-41957","markdown":"https://insights.sbomify.com/CVE-2022-41957/index.md","name":"CVE-2022-41957","record":{"aliases":["GHSA-2r7v-cmch-5x26"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js PDF library","requires_auth":"none","summary":"Attackers can cause denial of service in applications using the muhammara library by supplying maliciously crafted PDF files for parsing.","user_interaction":"not_required","vuln_class":"null_dereference"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"hummus","vendor":"hummus_project"},{"product":"muhammara","vendor":"muhammara_project"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-690","name":"Unchecked Return Value to NULL Pointer Dereference"}],"description":"Muhammara is a node module with c/cpp bindings to modify PDF with JavaScript for node or electron. The package muhammara before 2.6.2 and from 3.0.0 and before 3.3.0, as well as all versions of muhammara's predecessor package hummus, are vulnerable to Denial of Service (DoS) when supplied with a maliciously crafted PDF file to be parsed. The issue has been patched in muhammara version 3.4.0 and the fix has been backported to version 2.6.2. As a workaround, do not process files from untrusted sources. If using hummus, replace the package with muhammara.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"muhammara vulnerable to Unchecked Return Value to NULL Pointer Dereference","id":"CVE-2022-41957","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"null_dereference","year":"2022"},"n_packages":6,"n_references":3,"next":{"headline":"Deserialization Vulnerability by yaml config input in super-xray","id":"CVE-2022-41958"},"packages":[{"ecosystem":"npm","fixed":[],"introduced":["0"],"last_affected":[],"package":"hummus","purl":null,"source":"GHSA-2r7v-cmch-5x26"},{"ecosystem":"npm","fixed":[],"introduced":["0"],"last_affected":[],"package":"hummus","purl":"pkg:npm/hummus","source":"GHSA-2r7v-cmch-5x26"},{"ecosystem":"npm","fixed":["2.6.2"],"introduced":["0"],"last_affected":[],"package":"muhammara","purl":null,"source":"GHSA-2r7v-cmch-5x26"},{"ecosystem":"npm","fixed":["2.6.2"],"introduced":["0"],"last_affected":[],"package":"muhammara","purl":"pkg:npm/muhammara","source":"GHSA-2r7v-cmch-5x26"},{"ecosystem":"npm","fixed":["3.4.0"],"introduced":["3.0.0"],"last_affected":[],"package":"muhammara","purl":null,"source":"GHSA-2r7v-cmch-5x26"},{"ecosystem":"npm","fixed":["3.4.0"],"introduced":["3.0.0"],"last_affected":[],"package":"muhammara","purl":"pkg:npm/muhammara","source":"GHSA-2r7v-cmch-5x26"}],"prev":{"headline":"Autolab is vulnerable to file disclosure via remote handin feature","id":"CVE-2022-41956"},"products":["MuhammaraJS"],"published":"2022-11-28","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["julianhille"]},"summary":"Attackers can cause denial of service in applications using the muhammara library by supplying maliciously crafted PDF files for parsing.","url":"https://insights.sbomify.com/CVE-2022-41957/"}