# CVE-2022-41957: muhammara vulnerable to Unchecked Return Value to NULL Pointer Dereference

> Attackers can cause denial of service in applications using the muhammara library by supplying maliciously crafted PDF files for parsing.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Nov 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-2r7v-cmch-5x26

## What is CVE-2022-41957?

CVE-2022-41957 is a high-severity vulnerability in julianhille MuhammaraJS, published on 28 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Muhammara is a node module with c/cpp bindings to modify PDF with JavaScript for node or electron. The package muhammara before 2.6.2 and from 3.0.0 and before 3.3.0, as well as all versions of muhammara's predecessor package hummus, are vulnerable to Denial of Service (DoS) when supplied with a maliciously crafted PDF file to be parsed. The issue has been patched in muhammara version 3.4.0 and the fix has been backported to version 2.6.2. As a workaround, do not process files from untrusted sources. If using hummus, replace the package with muhammara.

Weakness: CWE-690 (Unchecked Return Value to NULL Pointer Dereference)

## Which versions are affected by CVE-2022-41957?

6 open source packages ship an affected version, including muhammara and hummus. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `muhammara` | npm | All versions | 2.6.2 |
| `muhammara` | npm | All versions | 2.6.2 |
| `muhammara` | npm | From 3.0.0 | 3.4.0 |
| `muhammara` | npm | From 3.0.0 | 3.4.0 |
| `hummus` | npm | All versions | None |
| `hummus` | npm | All versions | None |

Products: Hummus Project Hummus, Muhammara Project Muhammara.

## How do I fix CVE-2022-41957?

Upgrade muhammara to a fixed version for your release line: 2.6.2 or 3.4.0.

## Is CVE-2022-41957 being exploited?

There is no known exploitation of CVE-2022-41957 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-41957 and fix it if it is affected.

What it is: CVE-2022-41957 is a high-severity vulnerability in julianhille MuhammaraJS, published on 28 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-41957 in the wild and no public exploit code.

Affected packages and fixed versions:
- muhammara (npm): affected all versions; fixed in 2.6.2
- muhammara (npm): affected all versions; fixed in 2.6.2
- muhammara (npm): affected from 3.0.0; fixed in 3.4.0
- muhammara (npm): affected from 3.0.0; fixed in 3.4.0
- hummus (npm): affected all versions; no fix listed
- hummus (npm): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-41957/ (Markdown: https://insights.sbomify.com/CVE-2022-41957/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-41957
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-41957
- OSV: https://osv.dev/vulnerability/CVE-2022-41957

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-41957/
Summaries are generated and may contain mistakes; the official description above is the record.
