# CVE-2022-42003: Uncontrolled Resource Consumption in Jackson-databind

> Attackers can cause resource exhaustion via deep wrapper array nesting in jackson-databind when UNWRAP_SINGLE_VALUE_ARRAYS is enabled.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Oct 2022
- **Updated:** 7 Oct 2026
- **Also known as:** CLEANSTART-2025-LH78565, CLEANSTART-2026-AS89011, DEBIAN-CVE-2022-42003, ECHO-eda2-5b30-fb0d, GHSA-jjjh-jjxp-wpff, MINI-447r-3mgx-rrqv, MINI-64mc-3cqw-cqcm, MINI-mm53-mh5v-w7cm, MINI-p7h6-22mx-qgww, MINI-qp78-vrpv-rq2r, ROOT-APP-MAVEN-CVE-2022-42003, UBUNTU-CVE-2022-42003, openSUSE-SU-2024:14395-1

## What is CVE-2022-42003?

CVE-2022-42003 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 2 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In FasterXML jackson-databind before versions 2.13.4.1 and 2.12.17.1, resource exhaustion can occur because of a lack of a check in primitive value deserializers to avoid deep wrapper array nesting, when the UNWRAP_SINGLE_VALUE_ARRAYS feature is enabled.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2022-42003?

4 open source packages ship an affected version, including com.fasterxml.jackson.core:jackson-databind. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | From 2.13.0 | 2.13.4.2 |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | From 2.13.0 | 2.13.4.2 |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | From 2.4.0-rc1 | 2.12.7.1 |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | From 2.4.0-rc1 | 2.12.7.1 |
| `java-jwt` | openSUSE:Tumbleweed | All versions | 4.4.0-1.1 |

Products: Debian Debian Linux, Fasterxml Jackson-Databind, Netapp Oncommand Workflow Automation, Quarkus Quarkus.

## How do I fix CVE-2022-42003?

Upgrade com.fasterxml.jackson.core:jackson-databind to a fixed version for your release line: 2.13.4.2 or 2.12.7.1.

## Is CVE-2022-42003 being exploited?

There is no known exploitation of CVE-2022-42003 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-42003 and fix it if it is affected.

What it is: CVE-2022-42003 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 2 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-42003 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.fasterxml.jackson.core:jackson-databind (Maven): affected from 2.13.0; fixed in 2.13.4.2
- com.fasterxml.jackson.core:jackson-databind (Maven): affected from 2.13.0; fixed in 2.13.4.2
- com.fasterxml.jackson.core:jackson-databind (Maven): affected from 2.4.0-rc1; fixed in 2.12.7.1
- com.fasterxml.jackson.core:jackson-databind (Maven): affected from 2.4.0-rc1; fixed in 2.12.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-42003/ (Markdown: https://insights.sbomify.com/CVE-2022-42003/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-42003
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-42003
- OSV: https://osv.dev/vulnerability/CVE-2022-42003

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-42003/
Summaries are generated and may contain mistakes; the official description above is the record.
