CVE-2022-42004 Uncontrolled Resource Consumption in FasterXML jackson-databind

High 7.5 Published Updated

Attackers can cause resource exhaustion via deeply nested arrays in jackson-databind, requiring specific deserialization configurations.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-42004?

CVE-2022-42004 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 2 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

In FasterXML jackson-databind before 2.13.4, resource exhaustion can occur because of a lack of a check in BeanDeserializer._deserializeFromArray to prevent use of deeply nested arrays. An application is vulnerable only with certain customized choices for deserialization.

Weakness: CWE-502

Which versions are affected by CVE-2022-42004?

4 open source packages ship an affected version, including com.fasterxml.jackson.core:jackson-databind. It affects 4 products.

PackageAffectedFixed in
com.fasterxml.jackson.core:jackson-databind MavenFrom 2.13.02.13.4
com.fasterxml.jackson.core:jackson-databind MavenFrom 2.13.02.13.4
com.fasterxml.jackson.core:jackson-databind MavenFrom 2.4.0-rc12.12.7.1
com.fasterxml.jackson.core:jackson-databind MavenFrom 2.4.0-rc12.12.7.1

Products include Debian Debian Linux, Fasterxml Jackson-Databind, Netapp Oncommand Workflow Automation, Quarkus Quarkus.

How do I fix CVE-2022-42004?

Upgrade com.fasterxml.jackson.core:jackson-databind to a fixed version for your release line: 2.13.4 or 2.12.7.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2022-42004 being exploited?

There is no known exploitation of CVE-2022-42004 in the wild and no public exploit code.

All Debian Debian Linux vulnerabilities

Sources

Also known as CLEANSTART-2025-CH13291, CLEANSTART-2026-GG82498, CLSA-2026-1792508658, DEBIAN-CVE-2022-42004, ECHO-3da0-1a0f-e0ac, GHSA-rgv9-q543-rqg4 and 7 more.

Is CVE-2022-42004 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free