{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.ambari:ambari. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-42009 in the wild and no public exploit code.","fix":"Upgrade org.apache.ambari:ambari to 2.7.7 or later.","what":"CVE-2022-42009 is a high-severity code injection vulnerability in Apache Ambari, published on 12 Jul 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-42009 and fix it if it is affected.\n\nWhat it is: CVE-2022-42009 is a high-severity code injection vulnerability in Apache Ambari, published on 12 Jul 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-42009 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.ambari:ambari (Maven): affected from 2.7.0; fixed in 2.7.7\n- org.apache.ambari:ambari (Maven): affected from 2.7.0; fixed in 2.7.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-42009/ (Markdown: https://insights.sbomify.com/CVE-2022-42009/index.md)","id":"CVE-2022-42009","markdown":"https://insights.sbomify.com/CVE-2022-42009/index.md","name":"CVE-2022-42009","record":{"aliases":["GHSA-m384-pj54-5vr2"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Ambari","requires_auth":"low_privilege","summary":"A malicious authenticated user can execute arbitrary code remotely via SpringEL injection in Apache Ambari server agent.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"ambari","vendor":"apache"}],"cvss":{"score":8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-917","name":"Improper Neutralization of Special Elements used in an Expression Language Statement"}],"description":"SpringEL injection in the server agent in Apache Ambari version 2.7.0 to 2.7.6 allows a malicious authenticated user to execute arbitrary code remotely. Users are recommended to upgrade to 2.7.7.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Ambari: A malicious authenticated user can remotely execute arbitrary code in the context of the application.","id":"CVE-2022-42009","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"code_injection","year":"2022"},"n_packages":2,"n_references":1,"next":{"headline":"Denial of service in n/a","id":"CVE-2022-42010"},"packages":[{"ecosystem":"Maven","fixed":["2.7.7"],"introduced":["2.7.0"],"last_affected":[],"package":"org.apache.ambari:ambari","purl":null,"source":"GHSA-m384-pj54-5vr2"},{"ecosystem":"Maven","fixed":["2.7.7"],"introduced":["2.7.0"],"last_affected":[],"package":"org.apache.ambari:ambari","purl":"pkg:maven/org.apache.ambari/ambari","source":"GHSA-m384-pj54-5vr2"}],"prev":{"headline":"Uncontrolled Resource Consumption in FasterXML jackson-databind","id":"CVE-2022-42004"},"products":["Apache Ambari"],"published":"2023-07-12","related":[{"cvss_score":9.8,"headline":"Misconfiguration in Apache Ambari","id":"CVE-2017-5642","kev_date_added":null,"published":"2017-04-03"},{"cvss_score":9.8,"headline":"Command injection in n/a","id":"CVE-2014-3582","kev_date_added":null,"published":"2017-03-29"},{"cvss_score":9.8,"headline":"Apache Ambari Improper Access Control","id":"CVE-2016-6807","kev_date_added":null,"published":"2017-03-28"},{"cvss_score":8.8,"headline":"Apache Ambari: Remote Code Injection in Ambari Metrics and AMS Alerts","id":"CVE-2024-51941","kev_date_added":null,"published":"2025-01-21"},{"cvss_score":8.8,"headline":"Apache Ambari: Code Injection Vulnerability in Ambari Alert Definition","id":"CVE-2025-23196","kev_date_added":null,"published":"2025-01-21"},{"cvss_score":8.8,"headline":"Apache Ambari: authenticated users could perform command injection to perform RCE","id":"CVE-2023-50379","kev_date_added":null,"published":"2024-02-27"},{"cvss_score":8.1,"headline":"Information disclosure in Apache Ambari","id":"CVE-2018-8042","kev_date_added":null,"published":"2018-07-18"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-10-04","vendors":["Apache Software Foundation"]},"summary":"A malicious authenticated user can execute arbitrary code remotely via SpringEL injection in Apache Ambari server agent.","url":"https://insights.sbomify.com/CVE-2022-42009/"}