CVE-2022-4201 Server-side request forgery in GitLab
An attacker can exploit a blind SSRF vulnerability in GitLab to connect to local addresses by configuring a malicious GitLab Runner.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-4201?
CVE-2022-4201 is a low-severity server-side request forgery vulnerability in Gitlab Gitlab, published on 27 Jan 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A blind SSRF in GitLab CE/EE affecting all from 11.3 prior to 15.4.6, 15.5 prior to 15.5.5, and 15.6 prior to 15.6.1 allows an attacker to connect to local addresses when configuring a malicious GitLab Runner.
Weakness: CWE-918
Which versions are affected by CVE-2022-4201?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 11.3.0 | 15.4.6, 15.5.5, 15.6.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2022-4201?
Upgrade gitlab to a fixed version for your release line: 15.4.6, 15.5.5 or 15.6.1.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2022-4201 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-4201 exists.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2022-4201, GHSA-9ppv-xcv2-vhqr, UBUNTU-CVE-2022-4201.