# CVE-2022-4201: Server-side request forgery in GitLab

> An attacker can exploit a blind SSRF vulnerability in GitLab to connect to local addresses by configuring a malicious GitLab Runner.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jan 2023
- **Updated:** 27 Mar 2025
- **Also known as:** BIT-gitlab-2022-4201, GHSA-9ppv-xcv2-vhqr, UBUNTU-CVE-2022-4201

## What is CVE-2022-4201?

CVE-2022-4201 is a low-severity server-side request forgery vulnerability in Gitlab Gitlab, published on 27 Jan 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A blind SSRF in GitLab CE/EE affecting all from 11.3 prior to 15.4.6, 15.5 prior to 15.5.5, and 15.6 prior to 15.6.1 allows an attacker to connect to local addresses when configuring a malicious GitLab Runner.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2022-4201?

1 open source package ship an affected version, including gitlab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitlab` | Bitnami | From 11.3.0 | 15.4.6, 15.5.5, 15.6.1 |

Products: Gitlab Gitlab.

## How do I fix CVE-2022-4201?

Upgrade gitlab to a fixed version for your release line: 15.4.6, 15.5.5 or 15.6.1.

## Is CVE-2022-4201 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-4201 exists.

## Other vulnerabilities in Gitlab Gitlab

- [CVE-2026-97229](https://insights.sbomify.com/CVE-2026-97229/): GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound (critical 10.0, exploited in the wild)
- [CVE-2026-85706](https://insights.sbomify.com/CVE-2026-85706/): GitLab Community Edition and Enterprise Edition Path Traversal (critical 10.0, exploited in the wild)
- [CVE-2023-7028](https://insights.sbomify.com/CVE-2023-7028/): GitLab Community and Enterprise Editions Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2021-22205](https://insights.sbomify.com/CVE-2021-22205/): GitLab Community and Enterprise Editions Remote Code Execution (critical 10.0, exploited in the wild)
- [CVE-2021-39935](https://insights.sbomify.com/CVE-2021-39935/): GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF) (medium 6.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-4201 and fix it if it is affected.

What it is: CVE-2022-4201 is a low-severity server-side request forgery vulnerability in Gitlab Gitlab, published on 27 Jan 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-4201 exists.

Affected packages and fixed versions:
- gitlab (Bitnami): affected from 11.3.0; fixed in 15.4.6, 15.5.5, 15.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-4201/ (Markdown: https://insights.sbomify.com/CVE-2022-4201/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-4201
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-4201
- OSV: https://osv.dev/vulnerability/CVE-2022-4201

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-4201/
Summaries are generated and may contain mistakes; the official description above is the record.
