# CVE-2022-4203: X.509 Name Constraints Read Buffer Overflow

> A buffer overrun in OpenSSL's X.509 name constraint checking allows attackers to cause denial of service or potentially disclose memory contents.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Feb 2023
- **Updated:** 4 Nov 2025
- **Also known as:** ALPINE-CVE-2022-4203, CLEANSTART-2026-GM39950, DEBIAN-CVE-2022-4203, GHSA-w67w-mw4j-8qrv, RUSTSEC-2023-0008, UBUNTU-CVE-2022-4203

## What is CVE-2022-4203?

CVE-2022-4203 is a medium-severity memory corruption vulnerability in Openssl Openssl, published on 24 Feb 2023. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

A read buffer overrun can be triggered in X.509 certificate verification,
specifically in name constraint checking. Note that this occurs
after certificate chain signature verification and requires either a
CA to have signed the malicious certificate or for the application to
continue certificate verification despite failure to construct a path
to a trusted issuer.

The read buffer overrun might result in a crash which could lead to
a denial of service attack. In theory it could also result in the disclosure
of private memory contents (such as private keys, or sensitive plaintext)
although we are not aware of any working exploit leading to memory
contents disclosure as of the time of release of this advisory.

In a TLS client, this can be triggered by connecting to a malicious
server. In a TLS server, this can be triggered if the server requests
client authentication and a malicious client connects.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2022-4203?

3 open source packages ship an affected version, including openssl-src. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openssl-src` | crates.io | From 300.0.0 | 300.0.12 |
| `openssl-src` | crates.io | From 300.0.0 | 300.0.12 |
| `openssl-src` | crates.io | From 300.0.0 | 300.0.12 |

Products: Openssl Openssl.

## How do I fix CVE-2022-4203?

Upgrade openssl-src to 300.0.12 or later.

## Is CVE-2022-4203 being exploited?

There is no known exploitation of CVE-2022-4203 in the wild and no public exploit code.

## Other vulnerabilities in Openssl Openssl

- [CVE-2009-3245](https://insights.sbomify.com/CVE-2009-3245/): Null dereference in n/a (critical 10.0)
- [CVE-2006-3738](https://insights.sbomify.com/CVE-2006-3738/): Memory corruption in n/a (critical 10.0)
- [CVE-2026-63073](https://insights.sbomify.com/CVE-2026-63073/): Untrusted Sender DN Used as Format String in CMP Response Validation (critical 9.8)
- [CVE-2016-6309](https://insights.sbomify.com/CVE-2016-6309/): Use after free in n/a (critical 9.8)
- [CVE-2016-0799](https://insights.sbomify.com/CVE-2016-0799/): Integer overflow in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-4203 and fix it if it is affected.

What it is: CVE-2022-4203 is a medium-severity memory corruption vulnerability in Openssl Openssl, published on 24 Feb 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-4203 in the wild and no public exploit code.

Affected packages and fixed versions:
- openssl-src (crates.io): affected from 300.0.0; fixed in 300.0.12
- openssl-src (crates.io): affected from 300.0.0; fixed in 300.0.12
- openssl-src (crates.io): affected from 300.0.0; fixed in 300.0.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-4203/ (Markdown: https://insights.sbomify.com/CVE-2022-4203/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-4203
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-4203
- OSV: https://osv.dev/vulnerability/CVE-2022-4203

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-4203/
Summaries are generated and may contain mistakes; the official description above is the record.
