CVE-2022-4205 Other in GitLab
Attackers can override existing hashes using hexadecimal branch names, potentially corrupting repository data in GitLab.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-4205?
CVE-2022-4205 is a medium-severity vulnerability in Gitlab Gitlab, published on 27 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
In Gitlab EE/CE before 15.6.1, 15.5.5 and 15.4.6 using a branch with a hexadecimal name could override an existing hash.
Weakness: CWE-843
Which versions are affected by CVE-2022-4205?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 1.0.0 | 12.9.8, 15.5.5, 15.6.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2022-4205?
Upgrade gitlab to a fixed version for your release line: 12.9.8, 15.5.5 or 15.6.1.
Is CVE-2022-4205 being exploited?
There is no known exploitation of CVE-2022-4205 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2022-4205, GHSA-wqxm-qp29-hp7c, UBUNTU-CVE-2022-4205.