# CVE-2022-42110: Liferay Portal and Liferay DXP Vulnerable to XSS via the Announcements Module

> Remote attackers can inject arbitrary web script or HTML via the Announcements module in Liferay Portal.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Nov 2022
- **Updated:** 30 Apr 2025
- **Also known as:** GHSA-2qwm-9mg5-jwq8

## What is CVE-2022-42110?

CVE-2022-42110 is a medium-severity cross-site scripting vulnerability in Liferay Digital Experience Platform, published on 14 Nov 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A Cross-site scripting (XSS) vulnerability in the Announcements module in Liferay Portal 7.1.0 through 7.4.2, and Liferay DXP 7.1 before fix pack 27, 7.2 before fix pack 17, and 7.3 before service pack 3 allows remote attackers to inject arbitrary web script or HTML.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-42110?

6 open source packages ship an affected version, including com.liferay.portal:release.dxp.bom and com.liferay:com.liferay.announcements.web. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.liferay.portal:release.dxp.bom` | Maven | From 7.1.0 | 7.1.10.fp27 |
| `com.liferay.portal:release.dxp.bom` | Maven | From 7.1.0 | 7.1.10.fp27 |
| `com.liferay.portal:release.dxp.bom` | Maven | From 7.2.0 | 7.2.10.fp17 |
| `com.liferay.portal:release.dxp.bom` | Maven | From 7.2.0 | 7.2.10.fp17 |
| `com.liferay:com.liferay.announcements.web` | Maven | All versions | 6.0.11 |
| `com.liferay:com.liferay.announcements.web` | Maven | All versions | 6.0.11 |

Products: Liferay Digital Experience Platform, Liferay Dxp, Liferay Liferay Portal.

## How do I fix CVE-2022-42110?

Upgrade com.liferay.portal:release.dxp.bom to a fixed version for your release line: 7.1.10.fp27 or 7.2.10.fp17.

## Is CVE-2022-42110 being exploited?

There is no known exploitation of CVE-2022-42110 in the wild and no public exploit code.

## Other vulnerabilities in Liferay Digital Experience Platform

- [CVE-2024-8980](https://insights.sbomify.com/CVE-2024-8980/): Liferay Portal and Liferay DXP Vulnerable to CSRF in the Script Console (critical 9.6)
- [CVE-2023-42496](https://insights.sbomify.com/CVE-2023-42496/): Liferay Portal and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2023-42498](https://insights.sbomify.com/CVE-2023-42498/): Liferay Portal Language Override edit screen and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2024-25147](https://insights.sbomify.com/CVE-2024-25147/): Liferay Portal and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)
- [CVE-2024-26269](https://insights.sbomify.com/CVE-2024-26269/): Liferay Portal Frontend JS module's portlet.js and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-42110 and fix it if it is affected.

What it is: CVE-2022-42110 is a medium-severity cross-site scripting vulnerability in Liferay Digital Experience Platform, published on 14 Nov 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-42110 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.liferay.portal:release.dxp.bom (Maven): affected from 7.1.0; fixed in 7.1.10.fp27
- com.liferay.portal:release.dxp.bom (Maven): affected from 7.1.0; fixed in 7.1.10.fp27
- com.liferay.portal:release.dxp.bom (Maven): affected from 7.2.0; fixed in 7.2.10.fp17
- com.liferay.portal:release.dxp.bom (Maven): affected from 7.2.0; fixed in 7.2.10.fp17
- com.liferay:com.liferay.announcements.web (Maven): affected all versions; fixed in 6.0.11
- com.liferay:com.liferay.announcements.web (Maven): affected all versions; fixed in 6.0.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-42110/ (Markdown: https://insights.sbomify.com/CVE-2022-42110/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-42110
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-42110
- OSV: https://osv.dev/vulnerability/CVE-2022-42110

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-42110/
Summaries are generated and may contain mistakes; the official description above is the record.
