# CVE-2022-42113: Liferay Portal and Liferay DXP Vulnerable to XSS via the Document Library Module

> Remote attackers can inject arbitrary web script or HTML via the redirect parameter in the Document Library module.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Oct 2022
- **Updated:** 9 Jul 2026
- **Also known as:** GHSA-r32w-v775-5952

## What is CVE-2022-42113?

CVE-2022-42113 is a medium-severity cross-site scripting vulnerability in Liferay Liferay Portal, published on 18 Oct 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A Cross-site scripting (XSS) vulnerability in Document Library module in Liferay Portal 7.4.3.30 through 7.4.3.36, and Liferay DXP 7.4 update 30 through update 36 allows remote attackers to inject arbitrary web script or HTML via the `redirect` parameter.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-42113?

4 open source packages ship an affected version, including com.liferay.portal:release.dxp.bom and com.liferay:com.liferay.document.library.web. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.liferay.portal:release.dxp.bom` | Maven | From 7.4.13.u30 | 7.4.13.u37 |
| `com.liferay.portal:release.dxp.bom` | Maven | From 7.4.13.u30 | 7.4.13.u37 |
| `com.liferay:com.liferay.document.library.web` | Maven | All versions | 6.0.98 |
| `com.liferay:com.liferay.document.library.web` | Maven | All versions | 6.0.98 |

Products: Liferay Dxp, Liferay Liferay Portal.

## How do I fix CVE-2022-42113?

Upgrade com.liferay.portal:release.dxp.bom to 7.4.13.u37 or later.

## Is CVE-2022-42113 being exploited?

There is no known exploitation of CVE-2022-42113 in the wild and no public exploit code.

## Other vulnerabilities in Liferay Liferay Portal

- [CVE-2022-42120](https://insights.sbomify.com/CVE-2022-42120/): Liferay Portal and Liferay DXP Vulnerable to SQL Injection via the Fragment Module (critical 9.8)
- [CVE-2022-42122](https://insights.sbomify.com/CVE-2022-42122/): Liferay Portal and Liferay DXP Vulnerable to SQL Injection via Friendly URL Module (critical 9.8)
- [CVE-2023-35030](https://insights.sbomify.com/CVE-2023-35030/): Liferay Portal and Liferay DXP Vulnerable to CSRF via the Layout Module (high 8.8)
- [CVE-2021-29053](https://insights.sbomify.com/CVE-2021-29053/): Liferay Portal and Liferay DXP Vulnerable to Multiple SQL Injections (high 8.8)
- [CVE-2021-33321](https://insights.sbomify.com/CVE-2021-33321/): Liferay Portal and Liferay DXP insecure default configuration (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-42113 and fix it if it is affected.

What it is: CVE-2022-42113 is a medium-severity cross-site scripting vulnerability in Liferay Liferay Portal, published on 18 Oct 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-42113 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.liferay.portal:release.dxp.bom (Maven): affected from 7.4.13.u30; fixed in 7.4.13.u37
- com.liferay.portal:release.dxp.bom (Maven): affected from 7.4.13.u30; fixed in 7.4.13.u37
- com.liferay:com.liferay.document.library.web (Maven): affected all versions; fixed in 6.0.98
- com.liferay:com.liferay.document.library.web (Maven): affected all versions; fixed in 6.0.98

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-42113/ (Markdown: https://insights.sbomify.com/CVE-2022-42113/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-42113
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-42113
- OSV: https://osv.dev/vulnerability/CVE-2022-42113

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-42113/
Summaries are generated and may contain mistakes; the official description above is the record.
