{"answers":{"affected":"3 open source packages ship an affected version, including pgadmin4. It affects 2 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-4223 exists.","fix":"Upgrade pgadmin4 to 6.17 or later.","what":"CVE-2022-4223 is a high-severity command injection vulnerability in Fedoraproject Fedora, published on 13 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-4223 and fix it if it is affected.\n\nWhat it is: CVE-2022-4223 is a high-severity command injection vulnerability in Fedoraproject Fedora, published on 13 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-4223 exists.\n\nAffected packages and fixed versions:\n- pgadmin4 (PyPI): affected all versions; fixed in 6.17\n- pgadmin4 (PyPI): affected all versions; fixed in 6.17\n- pgadmin4 (PyPI): affected all versions; fixed in 6.17\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-4223/ (Markdown: https://insights.sbomify.com/CVE-2022-4223/index.md)","id":"CVE-2022-4223","markdown":"https://insights.sbomify.com/CVE-2022-4223/index.md","name":"CVE-2022-4223","record":{"aliases":["GHSA-3v6v-2x6p-32mc","PYSEC-2026-893"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"PostgreSQL management tool","requires_auth":"none","summary":"Unauthenticated attackers can execute arbitrary code on the pgAdmin server by manipulating the path used for PostgreSQL utility validation.","user_interaction":"required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"pgadmin_4","vendor":"pgadmin"}],"cvss":{"score":8.8,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"},{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"The pgAdmin server includes an HTTP API that is intended to be used to validate the path a user selects to external PostgreSQL utilities such as pg_dump and pg_restore. The utility is executed by the server to determine what PostgreSQL version it is from. Versions of pgAdmin prior to 6.17 failed to properly secure this API, which could allow an unauthenticated user to call it with a path of their choosing, such as a UNC path to a server they control on a Windows machine. This would cause an appropriately named executable in the target path to be executed by the pgAdmin server.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":1,"refs":[{"date":null,"kind":"nuclei","ref":"http/cves/2022/CVE-2022-4223.yaml","stars":null,"title":"pgAdmin \u003c 6.17 - Unauthenticated Remote Code Execution"}],"tier":"weaponised"},"has_fix":true,"headline":"pgadmin4 vulnerable to Code Injection","id":"CVE-2022-4223","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"fedoraproject:fedora","products":["fedoraproject:fedora"],"type":"command_injection","year":"2022"},"n_packages":3,"n_references":2,"next":{"headline":"CODESYS: Exposure of Resource to Wrong Sphere in CODESYS V3","id":"CVE-2022-4224"},"packages":[{"ecosystem":"PyPI","fixed":["6.17"],"introduced":["0"],"last_affected":[],"package":"pgadmin4","purl":null,"source":"GHSA-3v6v-2x6p-32mc"},{"ecosystem":"PyPI","fixed":["6.17"],"introduced":["0"],"last_affected":[],"package":"pgadmin4","purl":"pkg:pypi/pgadmin4","source":"GHSA-3v6v-2x6p-32mc"},{"ecosystem":"PyPI","fixed":["6.17"],"introduced":["0"],"last_affected":[],"package":"pgadmin4","purl":"pkg:pypi/pgadmin4","source":"PYSEC-2026-893"}],"prev":{"headline":"SourceCodester Canteen Management System POST Request ajax_invoice.php query sql injection","id":"CVE-2022-4222"},"products":["pgadmin4"],"published":"2022-12-13","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-14","vendors":["n/a"]},"summary":"Unauthenticated attackers can execute arbitrary code on the pgAdmin server by manipulating the path used for PostgreSQL utility validation.","url":"https://insights.sbomify.com/CVE-2022-4223/"}