{"answers":{"affected":"7 open source packages ship an affected version, including magento/community-edition and magento. It affects 2 products.","exploited":"There is no known exploitation of CVE-2022-42344 in the wild and no public exploit code.","fix":"Upgrade magento/community-edition to a fixed version for your release line: 2.3.7-p4, 2.4.3-p3 or 2.4.5.","what":"CVE-2022-42344 is a high-severity missing authorization vulnerability in Adobe Commerce, published on 20 Oct 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-42344 and fix it if it is affected.\n\nWhat it is: CVE-2022-42344 is a high-severity missing authorization vulnerability in Adobe Commerce, published on 20 Oct 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-42344 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- magento/community-edition (Packagist): affected all versions; fixed in 2.3.7-p4\n- magento/community-edition (Packagist): affected all versions; fixed in 2.3.7-p4\n- magento/community-edition (Packagist): affected from 2.4.0; fixed in 2.4.3-p3\n- magento/community-edition (Packagist): affected from 2.4.0; fixed in 2.4.3-p3\n- magento/community-edition (Packagist): affected from 2.4.4; fixed in 2.4.5\n- magento/community-edition (Packagist): affected from 2.4.4; fixed in 2.4.5\n- magento (Bitnami): affected all versions; fixed in 2.3.7, 2.4.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-42344/ (Markdown: https://insights.sbomify.com/CVE-2022-42344/index.md)","id":"CVE-2022-42344","markdown":"https://insights.sbomify.com/CVE-2022-42344/index.md","name":"CVE-2022-42344","record":{"aliases":["BIT-magento-2022-42344","GHSA-297f-r9w7-w492"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["data_read","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Adobe Commerce","requires_auth":"low_privilege","summary":"Authenticated attackers can exploit incorrect authorization in Adobe Commerce to access sensitive information and escalate privileges.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"adobe","cpe":[{"product":"commerce","vendor":"adobe"},{"product":"magento","vendor":"magento"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by an Incorrect Authorization vulnerability. An authenticated attacker can exploit this vulnerability to achieve information exposure and privilege escalation.","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"[CVE-2021-36032] Magento IDOR Leads to Account Takeover","id":"CVE-2022-42344","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"adobe:commerce","products":["adobe:commerce","magento:magento"],"type":"missing_authorization","year":"2022"},"n_packages":7,"n_references":1,"next":{"headline":"AEM Reflected XSS Arbitrary code execution","id":"CVE-2022-42345"},"packages":[{"ecosystem":"Bitnami","fixed":["2.3.7","2.4.5"],"introduced":["0","2.4.0"],"last_affected":[],"package":"magento","purl":"pkg:bitnami/magento","source":"BIT-magento-2022-42344"},{"ecosystem":"Packagist","fixed":["2.3.7-p4"],"introduced":["0"],"last_affected":[],"package":"magento/community-edition","purl":null,"source":"GHSA-297f-r9w7-w492"},{"ecosystem":"Packagist","fixed":["2.3.7-p4"],"introduced":["0"],"last_affected":[],"package":"magento/community-edition","purl":"pkg:composer/magento/community-edition","source":"GHSA-297f-r9w7-w492"},{"ecosystem":"Packagist","fixed":["2.4.3-p3"],"introduced":["2.4.0"],"last_affected":[],"package":"magento/community-edition","purl":null,"source":"GHSA-297f-r9w7-w492"},{"ecosystem":"Packagist","fixed":["2.4.3-p3"],"introduced":["2.4.0"],"last_affected":[],"package":"magento/community-edition","purl":"pkg:composer/magento/community-edition","source":"GHSA-297f-r9w7-w492"},{"ecosystem":"Packagist","fixed":["2.4.5"],"introduced":["2.4.4"],"last_affected":[],"package":"magento/community-edition","purl":null,"source":"GHSA-297f-r9w7-w492"},{"ecosystem":"Packagist","fixed":["2.4.5"],"introduced":["2.4.4"],"last_affected":[],"package":"magento/community-edition","purl":"pkg:composer/magento/community-edition","source":"GHSA-297f-r9w7-w492"}],"prev":{"headline":"Adobe Campaign Classic Server-Side Request Forgery Arbitrary file system read","id":"CVE-2022-42343"},"products":["Adobe Commerce"],"published":"2022-10-20","related":[{"cvss_score":10,"headline":"Adobe Commerce and Magento Improper Neutralization of Special Elements Used in a Template Engine","id":"CVE-2026-75650","kev_date_added":"2026-09-08","published":"2026-09-07"},{"cvss_score":9.8,"headline":"Adobe Commerce and Magento Open Source Improper Restriction of XML External Entity Reference (XXE)","id":"CVE-2024-34102","kev_date_added":"2024-07-17","published":"2024-06-13"},{"cvss_score":9.8,"headline":"Adobe Commerce and Magento Open Source Improper Input Validation","id":"CVE-2022-24086","kev_date_added":"2022-02-15","published":"2022-02-16"},{"cvss_score":9.3,"headline":"Adobe Commerce and Magento Unrestricted Upload of File with Dangerous Type","id":"CVE-2026-48356","kev_date_added":"2026-10-27","published":"2026-07-14"},{"cvss_score":9.1,"headline":"Adobe Commerce and Magento Incorrect Authorization Vulnerability","id":"CVE-2026-71362","kev_date_added":"2026-09-24","published":"2026-08-11"},{"cvss_score":9.1,"headline":"Adobe Commerce and Magento Improper Input Validation","id":"CVE-2025-54236","kev_date_added":"2025-10-24","published":"2025-09-09"},{"cvss_score":10,"headline":"Adobe Commerce Stored XSS Arbitrary code execution","id":"CVE-2022-35698","kev_date_added":null,"published":"2022-10-14"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["Adobe"]},"summary":"Authenticated attackers can exploit incorrect authorization in Adobe Commerce to access sensitive information and escalate privileges.","url":"https://insights.sbomify.com/CVE-2022-42344/"}