# CVE-2022-42344: [CVE-2021-36032] Magento IDOR Leads to Account Takeover

> Authenticated attackers can exploit incorrect authorization in Adobe Commerce to access sensitive information and escalate privileges.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Oct 2022
- **Updated:** 16 Sep 2024
- **Also known as:** BIT-magento-2022-42344, GHSA-297f-r9w7-w492

## What is CVE-2022-42344?

CVE-2022-42344 is a high-severity missing authorization vulnerability in Adobe Commerce, published on 20 Oct 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by an Incorrect Authorization vulnerability. An authenticated attacker can exploit this vulnerability to achieve information exposure and privilege escalation.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2022-42344?

7 open source packages ship an affected version, including magento/community-edition and magento. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `magento/community-edition` | Packagist | All versions | 2.3.7-p4 |
| `magento/community-edition` | Packagist | All versions | 2.3.7-p4 |
| `magento/community-edition` | Packagist | From 2.4.0 | 2.4.3-p3 |
| `magento/community-edition` | Packagist | From 2.4.0 | 2.4.3-p3 |
| `magento/community-edition` | Packagist | From 2.4.4 | 2.4.5 |
| `magento/community-edition` | Packagist | From 2.4.4 | 2.4.5 |
| `magento` | Bitnami | All versions | 2.3.7, 2.4.5 |

Products: Adobe Commerce, Magento Magento.

## How do I fix CVE-2022-42344?

Upgrade magento/community-edition to a fixed version for your release line: 2.3.7-p4, 2.4.3-p3 or 2.4.5.

## Is CVE-2022-42344 being exploited?

There is no known exploitation of CVE-2022-42344 in the wild and no public exploit code.

## Other vulnerabilities in Adobe Commerce

- [CVE-2026-75650](https://insights.sbomify.com/CVE-2026-75650/): Adobe Commerce and Magento Improper Neutralization of Special Elements Used in a Template Engine (critical 10.0, exploited in the wild)
- [CVE-2024-34102](https://insights.sbomify.com/CVE-2024-34102/): Adobe Commerce and Magento Open Source Improper Restriction of XML External Entity Reference (XXE) (critical 9.8, exploited in the wild)
- [CVE-2022-24086](https://insights.sbomify.com/CVE-2022-24086/): Adobe Commerce and Magento Open Source Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2026-48356](https://insights.sbomify.com/CVE-2026-48356/): Adobe Commerce and Magento Unrestricted Upload of File with Dangerous Type (critical 9.3, exploited in the wild)
- [CVE-2026-71362](https://insights.sbomify.com/CVE-2026-71362/): Adobe Commerce and Magento Incorrect Authorization Vulnerability (critical 9.1, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-42344 and fix it if it is affected.

What it is: CVE-2022-42344 is a high-severity missing authorization vulnerability in Adobe Commerce, published on 20 Oct 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-42344 in the wild and no public exploit code.

Affected packages and fixed versions:
- magento/community-edition (Packagist): affected all versions; fixed in 2.3.7-p4
- magento/community-edition (Packagist): affected all versions; fixed in 2.3.7-p4
- magento/community-edition (Packagist): affected from 2.4.0; fixed in 2.4.3-p3
- magento/community-edition (Packagist): affected from 2.4.0; fixed in 2.4.3-p3
- magento/community-edition (Packagist): affected from 2.4.4; fixed in 2.4.5
- magento/community-edition (Packagist): affected from 2.4.4; fixed in 2.4.5
- magento (Bitnami): affected all versions; fixed in 2.3.7, 2.4.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-42344/ (Markdown: https://insights.sbomify.com/CVE-2022-42344/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-42344
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-42344
- OSV: https://osv.dev/vulnerability/CVE-2022-42344

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-42344/
Summaries are generated and may contain mistakes; the official description above is the record.
