# CVE-2022-42466: XSS vulnerability, eg for String properties.

> Attackers can inject JavaScript into editable string properties, leading to script execution in the Apache Isis web application.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Oct 2022
- **Updated:** 8 May 2025
- **Also known as:** GHSA-7pfc-cc9x-8p4m

## What is CVE-2022-42466?

CVE-2022-42466 is a medium-severity cross-site scripting vulnerability in Apache Isis, published on 19 Oct 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Prior to 2.0.0-M9, it was possible for an end-user to set the value of an editable string property of a domain object to a value that would be rendered unchanged when the value was saved. In particular, the end-user could enter javascript or similar and this would be executed. As of this release, the inputted strings are properly escaped when rendered.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-42466?

2 open source packages ship an affected version, including org.apache.isis.core:isis-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.isis.core:isis-core` | Maven | All versions | 2.0.0-M9 |
| `org.apache.isis.core:isis-core` | Maven | All versions | 2.0.0-M9 |

Products: Apache Isis.

## How do I fix CVE-2022-42466?

Upgrade org.apache.isis.core:isis-core to 2.0.0-M9 or later.

## Is CVE-2022-42466 being exploited?

There is no known exploitation of CVE-2022-42466 in the wild and no public exploit code.

## Other vulnerabilities in Apache Isis

- [CVE-2022-42467](https://insights.sbomify.com/CVE-2022-42467/): h2 webconsole (available only in prototype mode) should nevertheless be disabled by default. (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-42466 and fix it if it is affected.

What it is: CVE-2022-42466 is a medium-severity cross-site scripting vulnerability in Apache Isis, published on 19 Oct 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-42466 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.isis.core:isis-core (Maven): affected all versions; fixed in 2.0.0-M9
- org.apache.isis.core:isis-core (Maven): affected all versions; fixed in 2.0.0-M9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-42466/ (Markdown: https://insights.sbomify.com/CVE-2022-42466/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-42466
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-42466
- OSV: https://osv.dev/vulnerability/CVE-2022-42466

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-42466/
Summaries are generated and may contain mistakes; the official description above is the record.
