{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.flume.flume-ng-sources:flume-jms-source. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-42468 in the wild and no public exploit code.","fix":"Upgrade org.apache.flume.flume-ng-sources:flume-jms-source to 1.11.0 or later.","what":"CVE-2022-42468 is a critical code injection vulnerability in Apache Flume, published on 26 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-42468 and fix it if it is affected.\n\nWhat it is: CVE-2022-42468 is a critical code injection vulnerability in Apache Flume, published on 26 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-42468 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.flume.flume-ng-sources:flume-jms-source (Maven): affected all versions; fixed in 1.11.0\n- org.apache.flume.flume-ng-sources:flume-jms-source (Maven): affected all versions; fixed in 1.11.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-42468/ (Markdown: https://insights.sbomify.com/CVE-2022-42468/index.md)","id":"CVE-2022-42468","markdown":"https://insights.sbomify.com/CVE-2022-42468/index.md","name":"CVE-2022-42468","record":{"aliases":["GHSA-9w4g-fp9h-3q2v"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Apache Flume","requires_auth":"none","summary":"Remote attackers can execute arbitrary code via JNDI injection in Apache Flume when using a JMS Source with an unsafe providerURL.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"flume","vendor":"apache"}],"cvss":{"score":9.8,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Apache Flume versions 1.4.0 through 1.10.1 are vulnerable to a remote code execution (RCE) attack when a configuration uses a JMS Source with an unsafe providerURL. This issue is fixed by limiting JNDI to allow only the use of the java protocol or no protocol.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Flume prior to 1.11.0 has an Improper Input Validation (JNDI Injection) in JMSSource","id":"CVE-2022-42468","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"code_injection","year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"Security feature bypass in FortiOS","id":"CVE-2022-42469"},"packages":[{"ecosystem":"Maven","fixed":["1.11.0"],"introduced":["0"],"last_affected":[],"package":"org.apache.flume.flume-ng-sources:flume-jms-source","purl":null,"source":"GHSA-9w4g-fp9h-3q2v"},{"ecosystem":"Maven","fixed":["1.11.0"],"introduced":["0"],"last_affected":[],"package":"org.apache.flume.flume-ng-sources:flume-jms-source","purl":"pkg:maven/org.apache.flume.flume-ng-sources/flume-jms-source","source":"GHSA-9w4g-fp9h-3q2v"}],"prev":{"headline":"h2 webconsole (available only in prototype mode) should nevertheless be disabled by default.","id":"CVE-2022-42467"},"products":["Apache Flume"],"published":"2022-10-26","related":[{"cvss_score":9.8,"headline":"Improper Input Validation (JNDI Injection) in JMSMessageConsumer","id":"CVE-2022-34916","kev_date_added":null,"published":"2022-08-21"},{"cvss_score":9.8,"headline":"Apache Flume vulnerable to a JNDI RCE in JMSSource","id":"CVE-2022-25167","kev_date_added":null,"published":"2022-06-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-05-07","vendors":["Apache Software Foundation"]},"summary":"Remote attackers can execute arbitrary code via JNDI injection in Apache Flume when using a JMS Source with an unsafe providerURL.","url":"https://insights.sbomify.com/CVE-2022-42468/"}