# CVE-2022-42468: Apache Flume prior to 1.11.0 has an Improper Input Validation (JNDI Injection) in JMSSource

> Remote attackers can execute arbitrary code via JNDI injection in Apache Flume when using a JMS Source with an unsafe providerURL.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Oct 2022
- **Updated:** 7 May 2025
- **Also known as:** GHSA-9w4g-fp9h-3q2v

## What is CVE-2022-42468?

CVE-2022-42468 is a critical code injection vulnerability in Apache Flume, published on 26 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache Flume versions 1.4.0 through 1.10.1 are vulnerable to a remote code execution (RCE) attack when a configuration uses a JMS Source with an unsafe providerURL. This issue is fixed by limiting JNDI to allow only the use of the java protocol or no protocol.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2022-42468?

2 open source packages ship an affected version, including org.apache.flume.flume-ng-sources:flume-jms-source. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.flume.flume-ng-sources:flume-jms-source` | Maven | All versions | 1.11.0 |
| `org.apache.flume.flume-ng-sources:flume-jms-source` | Maven | All versions | 1.11.0 |

Products: Apache Flume.

## How do I fix CVE-2022-42468?

Upgrade org.apache.flume.flume-ng-sources:flume-jms-source to 1.11.0 or later.

## Is CVE-2022-42468 being exploited?

There is no known exploitation of CVE-2022-42468 in the wild and no public exploit code.

## Other vulnerabilities in Apache Flume

- [CVE-2022-34916](https://insights.sbomify.com/CVE-2022-34916/): Improper Input Validation (JNDI Injection) in JMSMessageConsumer (critical 9.8)
- [CVE-2022-25167](https://insights.sbomify.com/CVE-2022-25167/): Apache Flume vulnerable to a JNDI RCE in JMSSource (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-42468 and fix it if it is affected.

What it is: CVE-2022-42468 is a critical code injection vulnerability in Apache Flume, published on 26 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-42468 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.flume.flume-ng-sources:flume-jms-source (Maven): affected all versions; fixed in 1.11.0
- org.apache.flume.flume-ng-sources:flume-jms-source (Maven): affected all versions; fixed in 1.11.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-42468/ (Markdown: https://insights.sbomify.com/CVE-2022-42468/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-42468
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-42468
- OSV: https://osv.dev/vulnerability/CVE-2022-42468

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-42468/
Summaries are generated and may contain mistakes; the official description above is the record.
