# CVE-2022-42699: WordPress Easy WP SMTP Plugin <= 1.5.1 is vulnerable to Remote Code Execution (RCE)

> Authenticated attackers can execute arbitrary code on WordPress sites using the Easy WP SMTP plugin.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 6 Dec 2022
- **Updated:** 28 Apr 2026
- **Also known as:** GHSA-xgjw-vr88-rxg7

## What is CVE-2022-42699?

CVE-2022-42699 is a critical code injection vulnerability in WPecommerce, Alexanderfoxc Easy WP SMTP, published on 6 Dec 2022. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Auth. Remote Code Execution vulnerability in Easy WP SMTP plugin <= 1.5.1 on WordPress.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2022-42699?

It affects 1 product.


Products: Wp-Ecommerce Easy Wp Smtp.

## How do I fix CVE-2022-42699?

No fix has been published for CVE-2022-42699 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-42699 being exploited?

There is no known exploitation of CVE-2022-42699 in the wild and no public exploit code.

## Other vulnerabilities in WPecommerce, Alexanderfoxc Easy WP SMTP

- [CVE-2019-25141](https://insights.sbomify.com/CVE-2019-25141/): Easy WP SMTP <= 1.3.9 - Missing Authorization to Arbitrary Options Update (critical 9.8)
- [CVE-2022-45829](https://insights.sbomify.com/CVE-2022-45829/): WordPress Easy WP SMTP Plugin <= 1.5.1 is vulnerable to Arbitrary File Deletion (high 8.7)
- [CVE-2020-35234](https://insights.sbomify.com/CVE-2020-35234/): Information disclosure in n/a (high 7.5)
- [CVE-2022-3334](https://insights.sbomify.com/CVE-2022-3334/): Easy WP SMTP < 1.5.0 - Admin+ PHP Objection Injection (high 7.2)
- [CVE-2022-45833](https://insights.sbomify.com/CVE-2022-45833/): WordPress Easy WP SMTP Plugin <= 1.5.1 is vulnerable to Directory Traversal (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-42699 and fix it if it is affected.

What it is: CVE-2022-42699 is a critical code injection vulnerability in WPecommerce, Alexanderfoxc Easy WP SMTP, published on 6 Dec 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-42699 in the wild and no public exploit code.

Affected product: WPecommerce, Alexanderfoxc Easy WP SMTP. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-42699/ (Markdown: https://insights.sbomify.com/CVE-2022-42699/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-42699
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-42699
- OSV: https://osv.dev/vulnerability/CVE-2022-42699

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-42699/
Summaries are generated and may contain mistakes; the official description above is the record.
