# CVE-2022-42731: django-mfa2 vulnerable to MFA Replay attack

> Attackers can replay device registration challenges to register unauthorized devices, potentially leading to account takeover in django-mfa2.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Oct 2022
- **Updated:** 20 May 2025
- **Also known as:** GHSA-vw39-2wj9-4q86, PYSEC-2022-303

## What is CVE-2022-42731?

CVE-2022-42731 is a high-severity vulnerability in n/a, published on 11 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

mfa/FIDO2.py in django-mfa2 before 2.5.1 and 2.6.x before 2.6.1 allows a replay attack that could be used to register another device for a user. The device registration challenge is not invalidated after usage.

Weakness: CWE-294 (Authentication Bypass by Capture-replay)

## Which versions are affected by CVE-2022-42731?

5 open source packages ship an affected version, including django-mfa2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django-mfa2` | PyPI | All versions | 2.5.1, 2.6.1 |
| `django-mfa2` | PyPI | All versions | 2.5.1 |
| `django-mfa2` | PyPI | All versions | 2.5.1 |
| `django-mfa2` | PyPI | From 2.6.0 | 2.6.1 |
| `django-mfa2` | PyPI | From 2.6.0 | 2.6.1 |

Products: Django-Mfa2 Project Django-Mfa2.

## How do I fix CVE-2022-42731?

Upgrade django-mfa2 to a fixed version for your release line: 2.5.1 or 2.6.1.

## Is CVE-2022-42731 being exploited?

There is no known exploitation of CVE-2022-42731 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-42731 and fix it if it is affected.

What it is: CVE-2022-42731 is a high-severity vulnerability in n/a, published on 11 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-42731 in the wild and no public exploit code.

Affected packages and fixed versions:
- django-mfa2 (PyPI): affected all versions; fixed in 2.5.1, 2.6.1
- django-mfa2 (PyPI): affected all versions; fixed in 2.5.1
- django-mfa2 (PyPI): affected all versions; fixed in 2.5.1
- django-mfa2 (PyPI): affected from 2.6.0; fixed in 2.6.1
- django-mfa2 (PyPI): affected from 2.6.0; fixed in 2.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-42731/ (Markdown: https://insights.sbomify.com/CVE-2022-42731/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-42731
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-42731
- OSV: https://osv.dev/vulnerability/CVE-2022-42731

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-42731/
Summaries are generated and may contain mistakes; the official description above is the record.
