CVE-2022-42735 Apache ShenYu Admin ultra vires
Low-privilege administrators can create users with higher privileges, allowing unauthorized privilege escalation in Apache ShenYu Admin.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-42735?
CVE-2022-42735 is a high-severity vulnerability in Apache ShenYu, published on 15 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Improper Privilege Management vulnerability in Apache Software Foundation Apache ShenYu.
ShenYu Admin allows low-privilege low-level administrators create users with higher privileges than their own.
This issue affects Apache ShenYu: 2.5.0.
Upgrade to Apache ShenYu 2.5.1 or apply patch https://github.com/apache/shenyu/pull/3958 https://github.com/apache/shenyu/pull/3958 .
Weakness: CWE-269
Which versions are affected by CVE-2022-42735?
2 open source packages ship an affected version, including org.apache.shenyu:shenyu-admin. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.shenyu:shenyu-admin Maven | All versions | 2.5.1 |
org.apache.shenyu:shenyu-admin Maven | All versions | 2.5.1 |
Products include Apache Shenyu.
How do I fix CVE-2022-42735?
Upgrade org.apache.shenyu:shenyu-admin to 2.5.1 or later.
Is CVE-2022-42735 being exploited?
There is no known exploitation of CVE-2022-42735 in the wild and no public exploit code.
Other vulnerabilities in Apache ShenYu
- CVE-2021-45029 Apache ShenYu 2.4.1 Groovy Code Injection & SpEL Injection
- CVE-2021-37580 Apache ShenYu Admin bypass JWT authentication
- CVE-2022-23944 Apache ShenYu 2.4.1 Improper access control
- CVE-2022-37435 Apache ShenYu Admin Improper Privilege Management
- CVE-2022-26650 Apache ShenYu (incubating) Regular expression denial of service
Sources
Also known as GHSA-vf8h-2wwj-jq22.