{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.shenyu:shenyu-admin. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-42735 in the wild and no public exploit code.","fix":"Upgrade org.apache.shenyu:shenyu-admin to 2.5.1 or later.","what":"CVE-2022-42735 is a high-severity vulnerability in Apache ShenYu, published on 15 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-42735 and fix it if it is affected.\n\nWhat it is: CVE-2022-42735 is a high-severity vulnerability in Apache ShenYu, published on 15 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-42735 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.shenyu:shenyu-admin (Maven): affected all versions; fixed in 2.5.1\n- org.apache.shenyu:shenyu-admin (Maven): affected all versions; fixed in 2.5.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-42735/ (Markdown: https://insights.sbomify.com/CVE-2022-42735/index.md)","id":"CVE-2022-42735","markdown":"https://insights.sbomify.com/CVE-2022-42735/index.md","name":"CVE-2022-42735","record":{"aliases":["GHSA-vf8h-2wwj-jq22"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache ShenYu Admin","requires_auth":"low_privilege","summary":"Low-privilege administrators can create users with higher privileges, allowing unauthorized privilege escalation in Apache ShenYu Admin.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"shenyu","vendor":"apache"}],"cvss":{"score":8.8,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-269","name":"Improper Privilege Management"}],"description":"Improper Privilege Management vulnerability in Apache Software Foundation Apache ShenYu.\n\nShenYu Admin allows low-privilege low-level administrators create users with higher privileges than their own.\n\nThis issue affects Apache ShenYu: 2.5.0.\n\nUpgrade to Apache ShenYu 2.5.1 or apply patch  https://github.com/apache/shenyu/pull/3958 https://github.com/apache/shenyu/pull/3958 .","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache ShenYu Admin ultra vires","id":"CVE-2022-42735","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"privilege_escalation","year":"2022"},"n_packages":2,"n_references":1,"next":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2022-42737"},"packages":[{"ecosystem":"Maven","fixed":["2.5.1"],"introduced":["0"],"last_affected":[],"package":"org.apache.shenyu:shenyu-admin","purl":null,"source":"GHSA-vf8h-2wwj-jq22"},{"ecosystem":"Maven","fixed":["2.5.1"],"introduced":["0"],"last_affected":[],"package":"org.apache.shenyu:shenyu-admin","purl":"pkg:maven/org.apache.shenyu/shenyu-admin","source":"GHSA-vf8h-2wwj-jq22"}],"prev":{"headline":"Path traversal in syngo Dynamics","id":"CVE-2022-42734"},"products":["Apache ShenYu"],"published":"2023-02-15","related":[{"cvss_score":9.8,"headline":"Apache ShenYu 2.4.1 Groovy Code Injection \u0026 SpEL Injection","id":"CVE-2021-45029","kev_date_added":null,"published":"2022-01-25"},{"cvss_score":9.8,"headline":"Apache ShenYu Admin bypass JWT authentication","id":"CVE-2021-37580","kev_date_added":null,"published":"2021-11-16"},{"cvss_score":9.1,"headline":"Apache ShenYu 2.4.1 Improper access control","id":"CVE-2022-23944","kev_date_added":null,"published":"2022-01-25"},{"cvss_score":8.8,"headline":"Apache ShenYu Admin Improper Privilege Management","id":"CVE-2022-37435","kev_date_added":null,"published":"2022-09-01"},{"cvss_score":7.5,"headline":"Apache ShenYu (incubating) Regular expression denial of service","id":"CVE-2022-26650","kev_date_added":null,"published":"2022-05-17"},{"cvss_score":7.5,"headline":"Apache ShenYu Password leakage","id":"CVE-2022-23223","kev_date_added":null,"published":"2022-01-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-03-19","vendors":["Apache Software Foundation"]},"summary":"Low-privilege administrators can create users with higher privileges, allowing unauthorized privilege escalation in Apache ShenYu Admin.","url":"https://insights.sbomify.com/CVE-2022-42735/"}