# CVE-2022-42856: Apple iOS Type Confusion

> A type confusion vulnerability in Safari allows arbitrary code execution via malicious web content, requiring users to update their Apple devices.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Yes, since 14 Dec 2022 (CISA KEV)
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Dec 2022
- **Updated:** 21 Oct 2025
- **Also known as:** ALSA-2023:0016, ALSA-2023:0021, DEBIAN-CVE-2022-42856, GHSA-qh2r-8xvg-hm24, RHSA-2023:0016, RHSA-2023:0021, RLSA-2023:0016, RLSA-2023:0021, SUSE-SU-2022:4634-1, UBUNTU-CVE-2022-42856

## What is CVE-2022-42856?

CVE-2022-42856 is a high-severity memory corruption vulnerability in Apple Ipados, published on 15 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A type confusion issue was addressed with improved state handling. This issue is fixed in Safari 16.2, tvOS 16.2, macOS Ventura 13.1, iOS 15.7.2 and iPadOS 15.7.2, iOS 16.1.2. Processing maliciously crafted web content may lead to arbitrary code execution. Apple is aware of a report that this issue may have been actively exploited against versions of iOS released before iOS 15.1..

Weakness: CWE-843 (Access of Resource Using Incompatible Type)

## Which versions are affected by CVE-2022-42856?

It affects 5 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `webkit2gtk3` | AlmaLinux:8 | All versions | 2.36.7-1.el8_7.1 |
| `webkit2gtk3-devel` | AlmaLinux:8 | All versions | 2.36.7-1.el8_7.1 |
| `webkit2gtk3-jsc` | AlmaLinux:8 | All versions | 2.36.7-1.el8_7.1 |
| `webkit2gtk3-jsc-devel` | AlmaLinux:8 | All versions | 2.36.7-1.el8_7.1 |
| `webkit2gtk3` | AlmaLinux:9 | All versions | 2.36.7-1.el9_1.1 |
| `webkit2gtk3-devel` | AlmaLinux:9 | All versions | 2.36.7-1.el9_1.1 |
| `webkit2gtk3-jsc` | AlmaLinux:9 | All versions | 2.36.7-1.el9_1.1 |
| `webkit2gtk3-jsc-devel` | AlmaLinux:9 | All versions | 2.36.7-1.el9_1.1 |
| `webkit2gtk3` | Red Hat:enterprise_linux:8::appstream | All versions | 0:2.36.7-1.el8_7.1 |
| `webkit2gtk3-debuginfo` | Red Hat:enterprise_linux:8::appstream | All versions | 0:2.36.7-1.el8_7.1 |
| `webkit2gtk3-debugsource` | Red Hat:enterprise_linux:8::appstream | All versions | 0:2.36.7-1.el8_7.1 |
| `webkit2gtk3-devel` | Red Hat:enterprise_linux:8::appstream | All versions | 0:2.36.7-1.el8_7.1 |
| `webkit2gtk3-devel-debuginfo` | Red Hat:enterprise_linux:8::appstream | All versions | 0:2.36.7-1.el8_7.1 |
| `webkit2gtk3-jsc` | Red Hat:enterprise_linux:8::appstream | All versions | 0:2.36.7-1.el8_7.1 |
| `webkit2gtk3-jsc-debuginfo` | Red Hat:enterprise_linux:8::appstream | All versions | 0:2.36.7-1.el8_7.1 |
| `webkit2gtk3-jsc-devel` | Red Hat:enterprise_linux:8::appstream | All versions | 0:2.36.7-1.el8_7.1 |
| `webkit2gtk3-jsc-devel-debuginfo` | Red Hat:enterprise_linux:8::appstream | All versions | 0:2.36.7-1.el8_7.1 |
| `webkit2gtk3` | Red Hat:enterprise_linux:9::appstream | All versions | 0:2.36.7-1.el9_1.1 |
| `webkit2gtk3-debuginfo` | Red Hat:enterprise_linux:9::appstream | All versions | 0:2.36.7-1.el9_1.1 |
| `webkit2gtk3-debugsource` | Red Hat:enterprise_linux:9::appstream | All versions | 0:2.36.7-1.el9_1.1 |
| `webkit2gtk3-devel` | Red Hat:enterprise_linux:9::appstream | All versions | 0:2.36.7-1.el9_1.1 |
| `webkit2gtk3-devel-debuginfo` | Red Hat:enterprise_linux:9::appstream | All versions | 0:2.36.7-1.el9_1.1 |
| `webkit2gtk3-jsc` | Red Hat:enterprise_linux:9::appstream | All versions | 0:2.36.7-1.el9_1.1 |
| `webkit2gtk3-jsc-debuginfo` | Red Hat:enterprise_linux:9::appstream | All versions | 0:2.36.7-1.el9_1.1 |
| `webkit2gtk3-jsc-devel` | Red Hat:enterprise_linux:9::appstream | All versions | 0:2.36.7-1.el9_1.1 |
| `webkit2gtk3-jsc-devel-debuginfo` | Red Hat:enterprise_linux:9::appstream | All versions | 0:2.36.7-1.el9_1.1 |
| `webkit2gtk3` | Rocky Linux:8 | All versions | 0:2.36.7-1.el8_7.1 |
| `webkit2gtk3` | Rocky Linux:9 | All versions | 0:2.36.7-1.el9_1.1 |
| `webkit2gtk3-soup2` | SUSE:Linux Enterprise Module for Basesystem 15 SP4 | All versions | 2.38.3-150400.4.25.1 |
| `webkit2gtk3` | SUSE:Linux Enterprise Module for Desktop Applications 15 SP4 | All versions | 2.38.3-150400.4.25.1 |
| `webkit2gtk4` | SUSE:Linux Enterprise Module for Development Tools 15 SP4 | All versions | 2.38.3-150400.4.25.1 |
| `webkit2gtk3` | openSUSE:Leap 15.4 | All versions | 2.38.3-150400.4.25.1 |
| `webkit2gtk3-soup2` | openSUSE:Leap 15.4 | All versions | 2.38.3-150400.4.25.1 |
| `webkit2gtk4` | openSUSE:Leap 15.4 | All versions | 2.38.3-150400.4.25.1 |

Products: Apple Ipados, Apple Iphone Os, Apple Macos, Apple Safari, Apple Tvos.

## How do I fix CVE-2022-42856?

Upgrade to a fixed version. US federal agencies must fix it by 4 Jan 2023.

## Is CVE-2022-42856 being exploited?

Yes. Attackers have exploited CVE-2022-42856 in the wild since at least 14 Dec 2022.

## Other vulnerabilities in Apple Ipados

- [CVE-2025-43300](https://insights.sbomify.com/CVE-2025-43300/): Apple iOS, iPadOS, and macOS Out-of-Bounds Write (critical 10.0, exploited in the wild)
- [CVE-2025-24201](https://insights.sbomify.com/CVE-2025-24201/): Apple Multiple Products WebKit Out-of-Bounds Write (critical 10.0, exploited in the wild)
- [CVE-2025-24085](https://insights.sbomify.com/CVE-2025-24085/): Apple Multiple Products Use-After-Free (critical 10.0, exploited in the wild)
- [CVE-2025-31200](https://insights.sbomify.com/CVE-2025-31200/): Apple Multiple Products Memory Corruption (critical 9.8, exploited in the wild)
- [CVE-2025-31201](https://insights.sbomify.com/CVE-2025-31201/): Apple Multiple Products Arbitrary Read and Write (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-42856 and fix it if it is affected.

What it is: CVE-2022-42856 is a high-severity memory corruption vulnerability in Apple Ipados, published on 15 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: Yes. Attackers have exploited CVE-2022-42856 in the wild since at least 14 Dec 2022.

Affected product: Apple Ipados. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-42856/ (Markdown: https://insights.sbomify.com/CVE-2022-42856/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-42856
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-42856
- OSV: https://osv.dev/vulnerability/CVE-2022-42856

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-42856/
Summaries are generated and may contain mistakes; the official description above is the record.
