CVE-2022-4289 Information disclosure in GitLab
GitLab fails to hide Google IAP details in Prometheus integration, allowing other users to leak sensitive configuration data from instance, group, or project settings.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-4289?
CVE-2022-4289 is a medium-severity vulnerability in Gitlab Gitlab, published on 9 Mar 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An issue has been discovered in GitLab affecting all versions starting from 15.3 before 15.7.8, versions of 15.8 before 15.8.4, and version 15.9 before 15.9.2. Google IAP details in Prometheus integration were not hidden, could be leaked from instance, group, or project settings to other users.
Which versions are affected by CVE-2022-4289?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 15.3.0 | 15.7.8, 15.8.4, 15.9.2 |
Products include Gitlab Gitlab.
How do I fix CVE-2022-4289?
Upgrade gitlab to a fixed version for your release line: 15.7.8, 15.8.4 or 15.9.2.
Is CVE-2022-4289 being exploited?
There is no known exploitation of CVE-2022-4289 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2022-4289, GHSA-v68j-qxmr-9486, UBUNTU-CVE-2022-4289.