# CVE-2022-42890: Apache Batik prior to 1.16 allows RCE via scripting

> Attackers can execute arbitrary Java code by processing malicious SVG files containing JavaScript in Apache Batik.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Oct 2022
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2022-42890, GHSA-rwqr-m72q-v6cm, UBUNTU-CVE-2022-42890

## What is CVE-2022-42890?

CVE-2022-42890 is a high-severity code injection vulnerability in Debian Debian Linux, published on 25 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability in Batik of Apache XML Graphics allows an attacker to run Java code from untrusted SVG via JavaScript. This issue affects Apache XML Graphics prior to 1.16. Users are recommended to upgrade to version 1.16.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2022-42890?

4 open source packages ship an affected version, including org.apache.xmlgraphics:batik and org.apache.xmlgraphics:batik-bridge. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.xmlgraphics:batik` | Maven | All versions | 1.16 |
| `org.apache.xmlgraphics:batik` | Maven | All versions | 1.16 |
| `org.apache.xmlgraphics:batik-bridge` | Maven | All versions | 1.16 |
| `org.apache.xmlgraphics:batik-bridge` | Maven | All versions | 1.16 |

Products: Apache Batik, Debian Debian Linux.

## How do I fix CVE-2022-42890?

Upgrade org.apache.xmlgraphics:batik to 1.16 or later.

## Is CVE-2022-42890 being exploited?

There is no known exploitation of CVE-2022-42890 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2018-8013](https://insights.sbomify.com/CVE-2018-8013/): Deserialization of Untrusted Data in Apache Batik (critical 9.8)
- [CVE-2020-11987](https://insights.sbomify.com/CVE-2020-11987/): Server-side request forgery (SSRF) in Apache Batik (high 8.2)
- [CVE-2022-41704](https://insights.sbomify.com/CVE-2022-41704/): Apache Batik prior to 1.16 allows RCE when loading untrusted SVG input (high 7.5)
- [CVE-2022-40146](https://insights.sbomify.com/CVE-2022-40146/): Jar url should be blocked by DefaultScriptSecurity (high 7.5)
- [CVE-2019-17566](https://insights.sbomify.com/CVE-2019-17566/): Server-side request forgery (SSRF) in Apache Batik (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-42890 and fix it if it is affected.

What it is: CVE-2022-42890 is a high-severity code injection vulnerability in Debian Debian Linux, published on 25 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-42890 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.xmlgraphics:batik (Maven): affected all versions; fixed in 1.16
- org.apache.xmlgraphics:batik (Maven): affected all versions; fixed in 1.16
- org.apache.xmlgraphics:batik-bridge (Maven): affected all versions; fixed in 1.16
- org.apache.xmlgraphics:batik-bridge (Maven): affected all versions; fixed in 1.16

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-42890/ (Markdown: https://insights.sbomify.com/CVE-2022-42890/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-42890
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-42890
- OSV: https://osv.dev/vulnerability/CVE-2022-42890

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-42890/
Summaries are generated and may contain mistakes; the official description above is the record.
