CVE-2022-4290 Cyr to Lat <= 3.5 - Authenticated SQL Injection
Authenticated attackers can inject SQL to extract sensitive database information via the Cyr to Lat WordPress plugin.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2022-4290?
CVE-2022-4290 is a high-severity SQL injection vulnerability in ivijanstefan Cyr to Lat Enhanced, published on 20 Oct 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
The Cyr to Lat plugin for WordPress is vulnerable to authenticated SQL Injection via the 'ctl_sanitize_title' function in versions up to, and including, 3.5 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This potentially allows authenticated users with the ability to add or modify terms or tags to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database. A partial patch became available in version 3.6 and the issue was fully patched in version 3.7.
Weakness: CWE-89
Which versions are affected by CVE-2022-4290?
It affects 1 product.
Products include Cyr to Lat Project Cyr to Lat.
How do I fix CVE-2022-4290?
No fix has been published for CVE-2022-4290 yet. Limit exposure of the affected software until one is available.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2022-4290 being exploited?
There is no known exploitation of CVE-2022-4290 in the wild and no public exploit code.
Sources
Also known as GHSA-hfmf-h398-rr97.