# CVE-2022-42906: Powerline Gitstatus vulnerable to arbitrary code execution

> Attackers can execute arbitrary code by tricking users into navigating to a malicious directory, as the plugin runs git commands automatically.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Oct 2022
- **Updated:** 15 May 2025
- **Also known as:** DEBIAN-CVE-2022-42906, DLA-3277-1, GHSA-w67g-6gjv-c599, PYSEC-2026-898, UBUNTU-CVE-2022-42906

## What is CVE-2022-42906?

CVE-2022-42906 is a high-severity command injection vulnerability in Debian Debian Linux, published on 13 Oct 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

powerline-gitstatus (aka Powerline Gitstatus) before 1.3.2 allows arbitrary code execution. git repositories can contain per-repository configuration that changes the behavior of git, including running arbitrary commands. When using powerline-gitstatus, changing to a directory automatically runs git commands in order to display information about the current repository in the prompt. If an attacker can convince a user to change their current directory to one controlled by the attacker, such as in a shared filesystem or extracted archive, powerline-gitstatus will run arbitrary commands under the attacker's control. NOTE: this is similar to CVE-2022-20001.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2022-42906?

3 open source packages ship an affected version, including powerline-gitstatus. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `powerline-gitstatus` | PyPI | All versions | 1.3.2 |
| `powerline-gitstatus` | PyPI | All versions | 1.3.2 |
| `powerline-gitstatus` | PyPI | All versions | 1.3.2 |

Products: Debian Debian Linux, Powerline Gitstatus Project Powerline Gitstatus.

## How do I fix CVE-2022-42906?

Upgrade powerline-gitstatus to 1.3.2 or later.

## Is CVE-2022-42906 being exploited?

There is no known exploitation of CVE-2022-42906 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-42906 and fix it if it is affected.

What it is: CVE-2022-42906 is a high-severity command injection vulnerability in Debian Debian Linux, published on 13 Oct 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-42906 in the wild and no public exploit code.

Affected packages and fixed versions:
- powerline-gitstatus (PyPI): affected all versions; fixed in 1.3.2
- powerline-gitstatus (PyPI): affected all versions; fixed in 1.3.2
- powerline-gitstatus (PyPI): affected all versions; fixed in 1.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-42906/ (Markdown: https://insights.sbomify.com/CVE-2022-42906/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-42906
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-42906
- OSV: https://osv.dev/vulnerability/CVE-2022-42906

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-42906/
Summaries are generated and may contain mistakes; the official description above is the record.
